Hexagon Geospatial
MENU

Developer Discussions

Discuss topics with other Hexagon Geospatial Power Portfolio developers and experts to get the most out of our products.
Showing results for 
Search instead for 
Do you mean 
Reply
Occasional Contributor
Posts: 11
Registered: ‎06-05-2017

The Legacy services with security lost the legend graphic icons in the geospatial portal built with

Dear

Any Legacy layer with security lost the legend graphic icons in any geospatial portal built with the Geospatial Portal SDK.

Making an inspection with the development tools of the browser, we realized that the Get is different from how a portal version 16.5 does it. For example:

Legacy service without security

http://ide2.minagri.gob.cl/erdas-apollo/vector/IDE_CIREN_PROPIEDADES_P?VERSION=1.1.1&REQUEST=GetLege...

Legacy service with security:

http://ide2.minagri.gob.cl/erdas-apollo/vector/IDE_CIREN_EROSION_INSULAR_M?VERSION=1.1.1&REQUEST=Get...

user: minagri
pass: 0S4jSqOY
Both work well. However the GetLegendGraphic made by the portal built with the SDK is different and does not work:

http://ide2.minagri.gob.cl/Ministerial/Proxy.WebClient.ashx?action=pictogram&mapServiceId=a2e9d500-2...

The next is an example of the geospatial portal with problems:
http://ide2.minagri.gob.cl/Ministerial/

user: mbarrera
pass: mbarrera

We need to know how solve this with the SDK, and/or  when the version 16.5 of the SDK will be released.

We generated a Support Ticket about that: 00029554

Thank you.
Alexis Muñoz
Imagine-IT

Staff
Posts: 251
Registered: ‎02-04-2016

Re: The Legacy services with security lost the legend graphic icons in the geospatial portal built w

[ Edited ]

Just a follow up on this post and the ticket logged (00029554) --> the issue may be related to having APOLLO 2018 and v16.4 SDK Portal Instance on the same machine.  We are not able to replicate the same issue (i.e. the legend icons are displaying fine under 2 of our SDK test instances).

 

The best option now is to wait for the SDK v16.5

Occasional Contributor
Posts: 11
Registered: ‎06-05-2017

Re: The Legacy services with security lost the legend graphic icons in the geospatial portal built w

That's right.

The issue is related to having Apollo 2018 and SDK 16.4. But we do not have the SDK installed on the same machine where the Geoportal is.


What is the new date for the release of the latest version of sdk?

Best
Alexis.

Staff
Posts: 251
Registered: ‎02-04-2016

Re: The Legacy services with security lost the legend graphic icons in the geospatial portal built w

Hi Alexis,

 

Soon I was told Smiley Happy 

 

Perhaps folks with insider info could chime in here  ?

 

Thanks

 

Frank

Do you need immediate support?
Please submit a Ticket through our
Development Ticket Portal.