Hexagon Geospatial
MENU

ERDAS APOLLO & ECW/JP2

Wondering how others have configured their ERDAS APOLLO server or what data they are crawling? The ERDAS APOLLO Discussion board is a place to find information, share ideas and more. Join the community, connect, contribute and share.
Showing results for 
Search instead for 
Do you mean 
Reply
Occasional Contributor
Posts: 15
Registered: ‎06-02-2018
Accepted Solution

APOLLO configuration error

Hello, 

I try to configure Erdas Apollo, when it finished, resulting error on database initialization failed and database update failed. 
what is the solution?

 

apollo error configuration.png

 

Thanks

Moderator
Moderator
Posts: 285
Registered: ‎11-16-2015

Re: APOLLO configuration error

Hi Amalia,

 

I suggest you to check the configwizard log (C:\Program Files\Hexagon\ERDAS APOLLO\configwizard\log.txt) and CatalogSchemaUpgrade.log (C:\Program Files\Hexagon\ERDAS APOLLO\log\CatalogSchemaUpgrade.log).

If you can't find the issue, I would suggest then to submit a support ticket.

 

 

Florent

Occasional Contributor
Posts: 15
Registered: ‎06-02-2018

Re: APOLLO configuration error

Hi flo, 

 

After i check the log file, here is the error :

 

line 10685 ; 10773; and 11188

DatabaseUpgrader started. Please check log file at C:\Program Files\Hexagon\ERDAS APOLLO\Server\..\log\APOLLOCore-databaseupgrader.log for details.
Database schema has required version 11.



2018-06-26 14:20:59,124 [4] DEBUG Intergraph.Apollo.Configuration.Pages.DatabaseSetupPage.DatabaseSetupPageViewModel - Process error:

Qt: Untested Windows version 6.3 detected!
The server version of this PostgreSQL is unknown, falling back to the client version.
DatabaseUpgrader started. Please check log file at C:\Program Files\Hexagon\ERDAS APOLLO\Server\..\log\APOLLOCore-databaseupgrader.log for details.
Database schema has required version 11.



2018-06-26 14:22:14,606 [11] DEBUG Intergraph.IWS.Configuration.Pages.DatabaseUI.DatabaseConfigurationViewModel - Process error:

Qt: Untested Windows version 6.3 detected!
The server version of this PostgreSQL is unknown, falling back to the client version.
Caused by: org.postgresql.util.PSQLException: FATAL: no pg_hba.conf entry for host "192.168.0.138", user "postgres", database "apollo_db", SSL off

i think it's about database upgrader but i don't know how to fix it. Do you know the solution?

Here, I attach the log file. 

And, i'm sorry, i don't know what do you mean by submitting a support ticket?

 

Thank you
Best regards,
amalia

Highlighted
Occasional Contributor
Posts: 15
Registered: ‎06-02-2018

Re: APOLLO configuration error

Hi, 

 

i already fix this problem. so, from my case, the solution is to edit the pg_hba.config file, by adding this host address :

 

 

host       all         all           127.0.0.1/32       md5
host       all         all           192.xxx.x.xxx/24   md5
host       all         all           0.0.0.0/0          md5

the middle address is my computer address.

 

Amalia

Do you need immediate support?
If you encounter a critical issue and need immediate assistance please submit a Service Request through our Support Portal.