Hexagon Geospatial
MENU

GeoMedia Smart Client

GeoMedia Smart Client community discussion board is where you can create, contribute and share information and knowledge in regards to configuring as well as working with GeoMedia Smart Client. Find your answers, share your knowledge and help build a strong GeoMedia Smart Client community.
Showing results for 
Search instead for 
Do you mean 
Reply
Contributor
Posts: 65
Registered: ‎11-20-2015
Accepted Solution

GMSC 2015 and Java 1.8.111 - No Javascript communication possible from workflow

With Java 1.8.111 there is NO javascript communication from a workflow to the client possible!

 

Doesn't matter if it is a IG.setMapCenter() or IG.captureGeometry().

 

Nothing is working anymore Smiley Mad

 

So DO NOT upgrade you Java VM!

 

Wolfgang

Contributor
Posts: 65
Registered: ‎11-20-2015

Re: GMSC 2015 and Java 1.8.111 - No Javascript communication possible from workflow

There is a new version of GMSC 2015 available where the problem is fixed.

Please contact support to get this version.

 

regards

Wolfgang

Contributor
Posts: 29
Registered: ‎10-12-2015

Re: GMSC 2015 and Java 1.8.111 - No Javascript communication possible from workflow

Hi,

 

Any idea if there will be an official release like EP for this fix?

Rohit Sinha
Hexagon Geospatial
Contributor
Posts: 65
Registered: ‎11-20-2015

Re: GMSC 2015 and Java 1.8.111 - No Javascript communication possible from workflow

I've been told to contact support where I will get the fix.

 

regards

Wolfgang

Moderator
Posts: 230
Registered: ‎02-08-2016

Re: GMSC 2015 and Java 1.8.111 - No Javascript communication possible from workflow

Hello.

An official EP for 2015 is planned for December.

 

Thank You,

Marc

Contributor
Posts: 42
Registered: ‎04-12-2016

Re: GMSC 2015 and Java 1.8.111 - No Javascript communication possible from workflow

This Patch also corrects the problem of the java certificate being expired, but my question is if the problem with the java certificate only happens when updating java to 1.8.111, or is this just based on date and not related with the java version.

 

Thanks in advance,

 

Nuno

Highlighted
Contributor
Posts: 65
Registered: ‎11-20-2015

Re: GMSC 2015 and Java 1.8.111 - No Javascript communication possible from workflow

The certificate used for signing expired. There is no relation to the version of your Java VM.

 

regards

Wolfgang

Do you need immediate support?
If you encounter a critical issue and need immediate assistance please submit a Service Request through our Support Portal.