Hexagon Geospatial
MENU

Support ERDAS APOLLO

Wondering how others have configured their ERDAS APOLLO server or what data they are crawling? The ERDAS APOLLO Discussion board is a place to find information, share ideas and more. Join the community, connect, contribute and share.
Showing results for 
Search instead for 
Do you mean 
Reply
Contributor
Posts: 68
Registered: ‎02-10-2017
Accepted Solution

Data Manager - OSM

Hi.

 

When opening Data Manager the OSM isn't available on the map window.

The option to use OSM in the Configuration Wizard was selected and I've looked to the DataManager ini file and the URL seems Ok.

I've 2 servers with the same configuration and it is working on one and not working on the other.

In the server that isn't working the OSM layer is shown in APOLLO Geospatial Portal. The problem is only on Data Manager.

 

Any hint?

Technical Evangelist
Posts: 815
Registered: ‎09-11-2015

Re: Data Manager - OSM

Hi António,

  1. Make sure that the OSM is switched on in the Data Manager
    (https://hexagongeospatial.fluidtopics.net/reader/Z~z_nSf7z~ZBtCD0LxbgBw/WavkFgJCk8Az0DzhOn8Gpg)
  2. Check the 'C:\Program Files (x86)\Hexagon\ERDAS APOLLO Data Manager\datamanager.ini' to see if it has this switch in place:
    -Dosm.tileserver.url=http://tile.openstreetmap.org/

Jan

Jan Neumann
Post Sales Engineer Web Applications
Hexagon Geospatial

Contributor
Posts: 68
Registered: ‎02-10-2017

Re: Data Manager - OSM

Hi Jan.

 

Thanks for the response.

Yes, the option was switched on when I runned the configuration wizard.

The parameter of the URL is equal to the one you sent.

 

Any other hint?

Contributor
Posts: 68
Registered: ‎02-10-2017

Re: Data Manager - OSM

Jan,

 

Found the problem.

The requests to OSM URL from the java process was being block while the request from the Portal wasn't.

 

Thanks for the inputs.

Staff
Posts: 110
Registered: ‎05-31-2016

Re: Data Manager - OSM

If it is your proxy blocking the OSM requests from Data Manager you should be able to add the proxy config to the end of this file 

C:\Program Files (x86)\Hexagon\ERDAS APOLLO Data Manager\datamanager.ini

 

-Dhttp.proxyHost=ProxyURL

-Dhttp.proxyPort=ProxyPort

 

 

More info can be found here https://docs.oracle.com/javase/7/docs/api/java/net/doc-files/net-properties.html

 

I think I did it this way a few years ago when I was having trouble with OSM in Data manager but I might be wrong, so if this still works make sure you let us all know.

 

Do you need immediate support?
If you encounter a critical issue and need immediate assistance please submit a Service Request through our Support Portal.