Hexagon Geospatial
MENU

Support ERDAS IMAGINE

Discuss and share topics of interest using ERDAS IMAGINE the world’s leading geospatial data authoring system.
Showing results for 
Search instead for 
Do you mean 
Reply
Super Contributor
Posts: 286
Registered: ‎02-09-2016

IMAGINE 2015 throws exception about conflict in active component version

Hi team,

 

Our client has IMAGINE 2015 and uses it to create a mosaic from some ecw and it throws exception below.

 

SnipImage.JPG

 

Check the event log we see the error entry

 

Activation context generation failed for "C:\Program Files\Hexagon\ERDAS IMAGINE 2015\bin\Win32Release\aaiRINAVProcessWrapper_AAI.exe".Error in manifest or policy file "" on line . A component version required by the application conflicts with another component version already active. Conflicting components are:. Component 1: C:\Windows\WinSxS\manifests\x86_microsoft.windows.common-controls_6595b64144ccf1df_6.0.9600.17031_none_a9efdb8b01377ea7.manifest. Component 2: C:\Windows\WinSxS\manifests\amd64_microsoft.windows.common-controls_6595b64144ccf1df_6.0.9600.17031_none_6242a4b3ecbb55a1.manifest.

 

We haven't come across this error, so appreciate all suggestions and ideas on investigating the problem.

 

Kind regards,

Staff
Posts: 485
Registered: ‎02-02-2016

Re: IMAGINE 2015 throws exception about conflict in active component version

Hi Bob,

 

This is a generic ECW SDK error message for compression failure. The user probably needs to perform some data preparation before carrying out the mosaic and compression processes. Please open a support ticket and we will assist you with this task.

 

Kind regards,

 

Stephen Bent

Hexagon Geospatial Support

 

Super Contributor
Posts: 286
Registered: ‎02-09-2016

Re: IMAGINE 2015 throws exception about conflict in active component version

Hi Stephen,

 

I am new to IMAGINE, so would you mind explaining a more what kind of data preparation that we should do?

 

Kind regards,

Highlighted
Staff
Posts: 141
Registered: ‎02-05-2016

Re: IMAGINE 2015 throws exception about conflict in active component version

Hi Bob,

As far as the term  data preparation in Mosaic is concerned, we did mean that  the user needs to make the input data compatible for IMAGINE Processing. As for example, the input data should have correct CRS and unit in the raster data header for any processing in IMAGINE. If the input raster tag has incorrect or incompatible tags, the user can use the Metadata Editor in IMAGINE to correct those tags. Similarly for better viewing the data in MosaicPro, the statistics and pyramid needs to be calculated before adding the data in the MosaocPro. Similarly if you need to set the NODATA value in the input data, that should be done before adding images in the MosaicPro.

 

FYI, I have looked at your all the error messages. I am assuming that all the service packs of IMAGINE 2015.x has been installed in the users system. There isn’t any information related to mosaic in your error messages  that can help. Also the event log message refers to a third party software (AAI) conflict. Therefore this case needs to be investigated through our support system.

 

Regards

Partha Roy

Super Contributor
Posts: 286
Registered: ‎02-09-2016

Re: IMAGINE 2015 throws exception about conflict in active component version

Hi Partha,

 

Thank you for the your information. It is very helpful. We suspect that it could be environmental issue and suggested him to try again on a different computer and it has been running well. We still wait to see the result but things look very positive.

 

Kind regards,

Staff
Posts: 141
Registered: ‎02-05-2016

Re: IMAGINE 2015 throws exception about conflict in active component version

Thanks Bob. Please do not hesitate to ask if you have any other question. 

Do you need immediate support?
If you encounter a critical issue and need immediate assistance please submit a Service Request through our Support Portal.