Hexagon Geospatial
MENU

Support GeoMedia Smart Client

GeoMedia Smart Client community discussion board is where you can create, contribute and share information and knowledge in regards to configuring as well as working with GeoMedia Smart Client. Find your answers, share your knowledge and help build a strong GeoMedia Smart Client community.
Showing results for 
Search instead for 
Do you mean 
Reply
Contributor
Posts: 66
Registered: ‎05-02-2016
Accepted Solution

GMSC2015 Compatibility with Macs

Hi,

 

One of our service providers is considering purchasing Mac tablets and was wondering if Smart Client is currently working ok on the Mac environment.

I recall speaking with one of the developers a year or so ago about this and there were limitations, but perhaps since the upgrade that is no longer the case.


Is this still the case with GMSC2015? Are there any issues to be aware of if it does work?

 

Regards,

 

Josh

Technical Evangelist
Posts: 215
Registered: ‎02-08-2016

Re: GMSC2015 Compatibility with Macs

Hello Josh

 

It is a supported platform and support has only seen one issue with Mac's.

I will check with development as I wasn't aware of any limitations.

 

Marc

Technical Evangelist
Posts: 215
Registered: ‎02-08-2016

Re: GMSC2015 Compatibility with Macs

Know limitations.
1. Printing does not work as GMSC 2015/2016  is not able to determine the printers DPI which results in a wrong print out
2. GMSC 2015/2016 No GPS support since the third-party library only supports windows.
3. GMSC 2015 ECW does not work. In version 2016 ECW is viable with the addition of GDAL into the products but only limited testing has been completed.

 

This information can also be found at here.

 

Contributor
Posts: 66
Registered: ‎05-02-2016

Re: GMSC2015 Compatibility with Macs

Thanks for this information Marc,

 

I'll let the service provider know.

They do use GPS and we have ECW images so I would recommend not purchasing Macs for this reason.

 

Regards,

 

Josh

Contributor
Posts: 66
Registered: ‎05-02-2016

Re: GMSC2015 Compatibility with Macs

Just to clarify, does GPS not work even with an external device?

Also, our aerials are ECW but have been tiled as JPG/features output type is Jpeg.

Will it still not work if we are using the published tiles?

 

Regards,

 

Josh

Technical Evangelist
Posts: 92
Registered: ‎10-20-2015

Re: GMSC2015 Compatibility with Macs

[ Edited ]

Hi Josh!

 

GPS:

there is no difference between an internal or external device. Both will not work.

 

Cached ECW:

In that case the GMSC servers must be able to read an ECW so that it can produce a JPG tile. That means 

 

  • GMSC 2015: Needs WebMapto read an ECW
  • GMSC 2016: Uses GDAL to read ECW

 

Client/ECWP- Mac issue:

Marc was talking about the client-side ECWP integration. In that case the java client consumes an ECWP/IWS service.

  • GMSC 2015: No mac/linux libraries are available
  • GMSC 2016: We added the mac/linux libraries but we didn't annouced that improvement because of the fact that only limited testing was possible. Therefore keep in mind that it works, but it has a BETA status.

 

Best Regards,

Steve

Contributor
Posts: 66
Registered: ‎05-02-2016

Re: GMSC2015 Compatibility with Macs

Hi,

 

Any word on when v2017 is available, and if these problems with Macs have been rectified with this version?

 

Regards,

 

Josh

Contributor
Posts: 47
Registered: ‎04-02-2017

Re: GMSC2015 Compatibility with Macs

Hi again,

 

Does Smart Client work on iPad also or is there the issue with Java?

 

Regards,

 

Josh

Technical Evangelist
Posts: 92
Registered: ‎10-20-2015

Re: GMSC2015 Compatibility with Macs

Hi Josh,

Smart Client isn't compatible with iOS.

 

In addition please note that GMSC 2018's Linux and Mac support is considered viable. However, these operating systems will no longer be supported in subsequent releases.

 

Therefore we recommend to use any Microsoft operating system which is certified for 

  • Java Runtime Environment (JRE) version 8 in case of GMSC 2016
  • Java Runtime Environment (JRE) version 10 in case of GMSC 2018

 

Quote:

https://www.hexagongeospatial.com/technical-documents/release-guides-2018/geomedia-smart-client-2018...

 

Best Regards,

Steve

Contributor
Posts: 47
Registered: ‎04-02-2017

Re: GMSC2015 Compatibility with Macs

Thanks for that Steve.

Do you need immediate support?
If you encounter a critical issue and need immediate assistance please submit a Service Request through our Support Portal.