Hexagon Geospatial
MENU

Support M.App Enterprise

Discuss topics with other M.App Enterprise Product pioneers and experts to get the most out of it.
Showing results for 
Search instead for 
Do you mean 
Reply
Contributor
Posts: 74
Registered: ‎10-14-2015
Accepted Solution

M.App Enterprise: BI Smart M.app: Smart M.App in EPSG:28992 is not projected correctly, shift ~100m.

Dear Community,

 

If in M.App Enterprise a BI Smart M.App is created in the projection EPSG:28992, the information on the map is not projected correctly and there is a offset about ~100. With my experience in GIS and Projectionsystems, I'm quite sure this is a datum shirt, with the transformation from WGS84 Datum to Amersfoort (NTv2).

 

Attached is the screenshot, where the red arrows define where the polygons (building footprints) should be. The background is correct because it is a service from the dutch kadaster.

 

Best Regards,

Wim Bozelie

Technical Evangelist
Posts: 86
Registered: ‎09-01-2015

Re: M.App Enterprise: BI Smart M.app: Smart M.App in EPSG:28992 is not projected correctly, shift ~1

We have to setup an app to investigate the problem. Next week we will have a look at it.

Technical Evangelist
Posts: 86
Registered: ‎09-01-2015

Re: M.App Enterprise: BI Smart M.app: Smart M.App in EPSG:28992 is not projected correctly, shift ~1

We have to setup an app to investigate the problem. Next week we will have a look at it.

Contributor
Posts: 74
Registered: ‎10-14-2015

Re: M.App Enterprise: BI Smart M.app: Smart M.App in EPSG:28992 is not projected correctly, shift ~1

Dear ,

 

For your investigantion I attached a shapefile in EPSG:28992 with some building footprints and you find a WMTS service of the Dutch Kadaster here below:

 

 

Use the background layer: brtachtergrondkaart

TileMatrix: EPSG:28992

 

Best Regards,

Wim

Technical Evangelist
Posts: 86
Registered: ‎09-01-2015

Re: M.App Enterprise: BI Smart M.app: Smart M.App in EPSG:28992 is not projected correctly, shift ~1

I tried your WMTS with your settings in QGIS I can't even connect to the WMTS. In GM Pro I can connect, but for you layer I just see an empty rectangle. 

 

Contributor
Posts: 74
Registered: ‎10-14-2015

Re: M.App Enterprise: BI Smart M.app: Smart M.App in EPSG:28992 is not projected correctly, shift ~1

Hey sschuett,

 

In the below link there are 2 how to video's, which demostrates how to add this WMTS in QGIS, and how to use this WMTS in M.App Enterprise. (I create a browser-app with this background)

 

https://we.tl/IGuYOr54R0

 

Best Regards,

WIm

Contributor
Posts: 74
Registered: ‎10-14-2015

Re: M.App Enterprise: BI Smart M.app: Smart M.App in EPSG:28992 is not projected correctly, shift ~1

Dear sschuett,

 

Can you give a status update of this issue? Will this be fixed in the next version? Support of the local coordinate reference system (Rijksdriehoekstelsel) EPSG28992 is important for the M.App Enterprise users in the Netherlands.

 

Thank you and Best Regards,

Wim

Highlighted
Contributor
Posts: 74
Registered: ‎10-14-2015

Re: M.App Enterprise: BI Smart M.app: Smart M.App in EPSG:28992 is not projected correctly, shift ~1

Dear sschuett,

 

We finally fixed this issue. M.App Enterprise uses the wrong projection defnition of EPSG28992. Replace the old EPSG28992.json file in both folders below, with the attached EPSG28992.json file. This file uses the NTv2 reprojection parameters.

 

  • \M.App Enterprise\MAppEditor\crs
  • \M.App Enterprise\MapViewer\crs

After replacing the files, clear the browser cache and restart the M.App Enterprise Bi-Wizard (MapEditor).

 

Best Regards,

Wim

Do you need immediate support?
If you encounter a critical issue and need immediate assistance please submit a Development Ticket through our Development Ticket Portal.