Hexagon Geospatial
MENU

WebGIS Q&A

WebGIS enables powerful geospatial web applications and services that securely share your organization’s rich geospatial data, and provides tools to deeply examine spatial data and create value added products, on demand.
Showing results for 
Search instead for 
Do you mean 

Consumer Portal won't start - 'Given crs was not provided by any of configured providers' errors

by Technical Evangelist on ‎06-29-2018 04:04 AM (135 Views)

Symptoms

Consumer Portal does not start and there are (apart of others) 'Given crs was not provided by any of configured providers' errors in browser developer tools console.

Diagnosis

If you open Network tab, on the developer console and refresh the page, you might observe some initial requests sent to the Backend, e.g.:

  • GET /backend/v2/connection/setcookie
  • GET /backend/v2/crs/code/EPSG:????

You should inspect those calls responses as the error message above indicates something's wrong with the Backend.

Simplest test for the Backend functionallity is sending this request via browser's address bar:

http://server/backend/v2/connection/setcookie
If you see a blank page, the cookie should have been set -> Backend works

Solution

Consumer Portal depends on Backend and BackendWMPS IIS applications that should be created after installation by the Configuration Wizard. In some cases, mainly during upgrade installations, these components might not be populated properly. Check IIS if you have both Backend and BackendWMPS applications created, if not:

  • Set up these two IIS applications manually:
    • Backend – using BackendAppPool (.NET4, Integrated)
      • pointing to C:\Program Files\Common Files\Hexagon\Services\AdminInstances\Backend
    • BackendWMPS – using BackendWMPSAppPool (.NET4, Integrated)
      • pointing to C:\Program Files\Common Files\Hexagon\Services\AdminInstances\BackendWMPS
  • In addition, BackendWMPS (used for WMPS search) must have Full Control enabled for BackendWMPSAppPool (IIS AppPool\BackendWMPSAppPool) on subfolders cache and log

If you can't find the Backends folders, neither zipped under C:\Program Files\Common Files\Hexagon\Services\AdminInstances, you will likely need to repair GeoMedia WebMap (or Geospatial Portal) installation.

 

Contributors