Hexagon Geospatial
MENU

WebGIS

Need a push in the right direction when configuring WebMap, Portal or SDI services? Looking for hints and tips, or just looking for Ideas and information? The WebGIS discussion board is where you start those discussions, connect and share information.
Showing results for 
Search instead for 
Do you mean 
Reply
Contributor
Posts: 38
Registered: ‎07-12-2016

Re: Portal Printing

Thanks Jan,

 

So no chance of a hotfix for the single SR? This is a fairly major issue for us to have to wait until the next major release, which we don't even know an ETA for.

 

Jason

Contributor
Posts: 38
Registered: ‎07-12-2016

Re: Portal Printing

We've only recently upgraded to 2016 and found this issue. The original poster raised this over a year ago and still has no fix?!? Wow.

Technical Evangelist
Posts: 927
Registered: ‎09-11-2015

Re: Portal Printing

[ Edited ]

Hi Jason,

 

I'm sorry for your disappointment but there were other serious issues found and fixed on 2016 release. This particular problem could be possibly worked around by using different services (WMS / WFS), or publish the layers into the same WMPS and use only this one. Remember that WMPS can hold more than one Map Windows...

 

If you require to have this fixed ASAP, please create a support ticket and then it can be escalated providing business severity.

 

Regards,

Jan

Jan Neumann
Post Sales Engineer Web Applications
Hexagon Geospatial

Technical Evangelist
Posts: 927
Registered: ‎09-11-2015

Re: Portal Printing

Hi guys,

 

I've re-tested this case on Windows Server 2012 R2 + WebGIS 16 EP02 and can no longer reproduce it. I added 11 WMPS services (all of them contain demo data) and Portal continue to work normally. I haven't received "Session Resuming" error, not even when I tried to save the Map/Workspace. This leads me to suspicion that there must be some configuration problem...

 

Jan

Jan Neumann
Post Sales Engineer Web Applications
Hexagon Geospatial

Regular Contributor
Posts: 190
Registered: ‎07-27-2016

Re: Portal Printing

Hi Jan,

We are currently running Windows 2008 R2 at the client , they are in the process of upgrading but is can take months.

Currently running 5 portal ranging from 18 WMPS services down to 3.

All experincing the same problem.

If memory serves me correct you did had a look at it on site a year or 2 back and could also not resolve it , think it was on Ver 16 though.

 

In the meantime I have created an empty portal on Win Server 2012 R2 that only contains bacdrop data (Google and Bing)

And a configured print service , at this stage when I print the print does not contain any data (Bing Or Google)

 

Then also to come back to your earlier statement , regarding your working 11 WMPS services , tou you render them as svg png ....?

Will this make a difference?

 

Kind Regards

Jacques

Technical Evangelist
Posts: 927
Registered: ‎09-11-2015

Re: Portal Printing

Hi Jacques,

 

Yes, I was able to reproduce the problem by that time, but I tested it on Windows 10. And in time of plain 2016 or EP01 (can't remember now). So we have two variables here that might or might not have an influence (op.system, EP).

 

In my recent test, I connected to a single WMPS service but selected from 11 predefined demo WMPSes. During registration I choosed a combination of PNG and SVG. Everything printed fine.

 

Regards,

Jan

 

PS: There is a known issue with SVG format when complex SVG features might not print. This is going to be resolved in EP03.

Jan Neumann
Post Sales Engineer Web Applications
Hexagon Geospatial

Regular Contributor
Posts: 190
Registered: ‎07-27-2016

Re: Portal Printing

Hi Jan,

 

Yes I agree the results is erractic between system setups.

Here we get the same result though , I get the same result running SDK from my Windows 10 Laptop as the results from running SDK from Windows Server 2008 R2.

But I have to say , in both scenarios the same printservice is used (Windows Server 2008 R2)

 

I will create a new print service on my laptop and play around with portal to see what the results are.

 

At this stage all portals only print the borders and legend with nothing in them.

 

Kind Regards

Jacques

Regular Contributor
Posts: 190
Registered: ‎07-27-2016

Re: Portal Printing

Hi Jan,

 

So I did some testing and this is what I came up with.

It looks like our main issue is svg on some of the wmps services.

So I added the wmps services one by one testing the printing after each wmps.

As soon as I get an empty print page I remove the last wmps and re-add it as png or jpeg (from svg) then then it print again.

 

The other main concern is the fact that google and bing is not printing , our aerial imagery from Apollo print fine.

Any idea why this could be (get no errors related to this issue)

 

Kind Regards

Jacques

Technical Evangelist
Posts: 927
Registered: ‎09-11-2015

Re: Portal Printing

Hi Jacques,

 

Both are known issues that are going to be fixed in the next EP:

1) Cannot print Bing / Google Maps (SR-4605)

2) WMPS SVG not always printed (SR-4782)

 

Best Regards,

Jan

Jan Neumann
Post Sales Engineer Web Applications
Hexagon Geospatial

Regular Contributor
Posts: 190
Registered: ‎07-27-2016

Re: Portal Printing

Hi Jan,

 

Thanks for all the effort,appreciate it.

Will wait for the next EP in great anticipation then.

 

 

Kind Regards

Jacques

Do you need immediate support?
If you encounter a critical issue and need immediate assistance please submit a Service Request through our Support Portal.