APOLLO & ECW/JP2 Discussions

Wondering how others have configured their ERDAS APOLLO server or what data they are crawling? The ERDAS APOLLO Discussion board is a place to find information, share ideas and more. Join the community, connect, contribute and share.
Showing results for 
Search instead for 
Do you mean 
Reply
Super Contributor
Posts: 455
Registered: ‎10-12-2015
Accepted Solution

Apollo 2018 adv/pro - data manager - Java version requirement

For Apollo 2018 Data Manger - is there a required version of Java?

 

I assume https://community.hexagongeospatial.com/t5/ERDAS-APOLLO-Q-A/APOLLO-2018-16-5-only-support-JAVA-versi... applies to Apollo 2018 server components, not Apollo Data Manager 2018?

 

Looking at the release guide:

Minimum Client Software
Java JRE v1.6 or higher (for administration console use)

Seems to apply to both essentials and Apollo Data Manager.

 

Above that under adv/pro only it says 

Latest JRE or JDK 1.8 (external
dependency)


 which implies using Java JRE 10 should be fine for data manager?

 

I've run up data manager 2018 with Java 10 and seems ok, but have not exhaustively tested. Also seemed to go ok with Java 7 and Java 8.

 

 

 

thanks

Technical Evangelist
Posts: 987
Registered: ‎07-30-2015

Re: Apollo 2018 adv/pro - data manager - Java version requirement

I don't think Apollo development team tested JAVA 10 on data manager, they only tested on JAVA 8.

On the safe side, you should use latest JAVA 8.

 

The JAVA version on release guide is not very clear on JAVA version.

 

best

Haiyan

Super Contributor
Posts: 455
Registered: ‎10-12-2015

Re: Apollo 2018 adv/pro - data manager - Java version requirement

Customer also runs GMSC which is being upgrade to version 2018. GMSC 2018 requires Java 10.

Customer does not want to run both Java 8 and Java 10 (they only deploy single version).

 

What is the support position for Apollo Data Manager 2018 and Java 10?

i.e. if they upgrade to Java 10 will they be supported?

 

My read of the release guide says that yes they are supported as it specifies java 7 or above which implies they will be supported by product centre if there is an issue.

Technical Evangelist
Posts: 987
Registered: ‎07-30-2015

Re: Apollo 2018 adv/pro - data manager - Java version requirement

Apollo data manager comes with its own 32bit JAVA 7, so you don't need to install additional JAVA for dat amanager.

But Apollo 2016, 2018 server only work with 64bit JAVA 8, JAVA 10 will not work with Apollo server.

 

best

haiyan