APOLLO & ECW/JP2 Discussions

Wondering how others have configured their ERDAS APOLLO server or what data they are crawling? The ERDAS APOLLO Discussion board is a place to find information, share ideas and more. Join the community, connect, contribute and share.
Showing results for 
Search instead for 
Do you mean 
Reply
Highlighted
Contributor
Posts: 37
Registered: ‎05-13-2016
Accepted Solution

Can't get a JPEG with a .gim file to load

Hi --

 

I am trying to load several JPEG files into the Apollo catalog that have no georeference points.  Based on the tutorial on loading business data, it would seem that if I could generate a .gim file, it would load along with the JPEG and provide a reference point.  At least it did that with the fire hydrants. 

 

I have attached a .gim file called image1.jpg.gim that is alone in a directory with image1.jpg.  When I try to crawl the directory, nothing happens.  I suspect (hope) that the problem is that there's a syntax problem in the .gim file.  I've also tried changing the jpg references in the .gim to txt and the JPEG to txt, and it still doesn't load.  [Please note that because this board doesn't like files with extensions .jpg.gim, I've called it .gif.  However, what I tried to load is .jpg.gim]

 

Can anybody tell me [1] why the combined image1.jpg and image1.jpg.gim won't load and [2] what I have to do to the .gim file to make it work?

 

Thanks!

Staff
Posts: 135
Registered: ‎05-31-2016

Re: Can't get a JPEG with a .gim file to load

[ Edited ]

I cant see your attachments, but I hope this helps.

 

I just did a quick test using a non georeferenced jpg (DSC_0182.jpg) and a gim file (DSC_0182.jpg.gim) and it worked for me.

 

Here is my Gim file contents

 

<?xml version='1.0' encoding='utf-8' ?>
<item xmlns="http://schema.erdas.com/apollo/catalog"
             xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
             xsi:schemaLocation="http://schema.erdas.com/apollo/catalog
             http://schema.erdas.com/apollo/catalog/generic-item-metadata-1.0.xsd"
             version="1.0" 
             type="image/jpeg"
             identifiedBy="identifier">        
     <identifier>F4ACEB380CBE4C799BDE6150946FC26F</identifier>
     <name>Can</name>
     <title>Coke_Can</title>
     <description>Coke can sitting on my desk</description>
     <tags>Australia, West Leedervile, Hexagon Office</tags>
     <footprint srs="EPSG:4326"> POINT (115.838140 -31.941780)</footprint>
     <resource-url mimeType="image/jpeg">DSC_0182.jpg</resource-url>
     <icon-url mimeType="image/jpeg">DSC_0182.jpg</icon-url>
</item>

 Capture.JPG

 

Documentation describing the use of GIM files is here https://hexagongeospatial.fluidtopics.net/book#!book;uri=39d06d76664a3355296cf4880b8180c6;breadcrumb... 

 

 

Regards,

Phil

Contributor
Posts: 37
Registered: ‎05-13-2016

Re: Can't get a JPEG with a .gim file to load

Sorry for the delay, but we were in Washington for the March for Science.  Yes, this solved the problem!  Thank you.