APOLLO & ECW/JP2 Discussions

Wondering how others have configured their ERDAS APOLLO server or what data they are crawling? The ERDAS APOLLO Discussion board is a place to find information, share ideas and more. Join the community, connect, contribute and share.
Showing results for 
Search instead for 
Do you mean 
Occasional Contributor
Posts: 19
Registered: ‎11-21-2016

Catalog Explorer (the new one) can't read my ecwp



I have just installed the new ERDAS Apollo Client - Catalog Explorer. It works very fast - at first i was thinking that when i am adding to map my ecw file, it is added as a ecwp (but is still WMS - very fast).

When i noticed that i am using WMS instead of ECWP i have tried to add ecwp. For the given example (ecwp://demo-apollo.hexagongeospatial.com/SampleIWS/images/geodetic/bluemarble.ecw) it works fine - at least the image was displayed. But for my image it returs error - request failed.


My ECWP works fine in ERDAS Imagine 2020 so i guess it is set propoerly



Is it a bug?


Posts: 379
Registered: ‎11-16-2015

Re: Catalog Explorer (the new one) can't read my ecwp



It seems to be a bug, I have also an issue with ecwp and other layers, you could submit a support ticket for that.

This functionality might have bug(s) as it is still in an experimental phase:


Posts: 3
Registered: ‎12-23-2019

Re: Catalog Explorer (the new one) can't read my ecwp

Hi tmalej, I just tried to load ecwp://demo.intergraph.pl/Orto/RGB_2016.ecw, and looking at the console the error is:

Access to XMLHttpRequest at 'http://demo.intergraph.pl/erdas-iws/ecwp3.dll?cmd=0&v=1&layer=/Orto/RGB_2016.ecw' from origin 'http://trident-dev.luciad.com:8080' has been blocked by CORS policy: The 'Access-Control-Allow-Origin' header contains the invalid value 'localhost'.

This makes me suspect that CORS is incorrectly configured on the server.

Unfortunately due to CORS being a security feature CORS failures areren't reported to the application, the only way to check them if via opening the console.


The header sent was:

Access-Control-Allow-Origin: localhost

So this should work if you change your CORS setting to '*' or the serer name.


Also I know this feature is marked as being in an experimental phase, but don't let that dissuade you from reporting bugs. Everything should work, it's more that some features aren't implemented yet, and browser support is limited.