APOLLO & ECW/JP2 Discussions

Wondering how others have configured their ERDAS APOLLO server or what data they are crawling? The ERDAS APOLLO Discussion board is a place to find information, share ideas and more. Join the community, connect, contribute and share.
Showing results for 
Search instead for 
Do you mean 
Reply
Regular Contributor
Posts: 196
Registered: ‎03-04-2016

ERDAS APOLLO 2016 update failed

[ Edited ]

Hello community,

 

One of my clients updated their APOLLO 2016 installation with the following patches:

  • 16.00.0000.1025
  • 16.00.0000.1104

After running the Config Wizard, he gets this error message:

 

roorelementmissing.png

 

Here is a part of the logfile:

 

 

 
2017-07-05 11:02:54,064 [7] INFO  Intergraph.Apollo.Configuration.Actions.ApolloConfigurationAction - Beginning ERDAS APOLLO configuration action execution
2017-07-05 11:02:54,064 [7] DEBUG Intergraph.Apollo.Configuration.Actions.ApolloConfigurationAction - Stopping services
2017-07-05 11:02:54,067 [7] DEBUG Intergraph.Apollo.Configuration.Actions.ApolloConfigurationAction - Getting service controller for: APOLLOTOMCAT7
2017-07-05 11:02:54,069 [7] DEBUG Intergraph.Apollo.Configuration.Actions.ApolloConfigurationAction - Service is in state: Stopped
2017-07-05 11:02:54,069 [7] DEBUG Intergraph.Apollo.Configuration.Actions.ApolloConfigurationAction - Service is already stopped
2017-07-05 11:02:54,069 [7] DEBUG Intergraph.Apollo.Configuration.Actions.ApolloConfigurationAction - Getting service controller for: APOLLOSmartSync
2017-07-05 11:02:54,069 [7] DEBUG Intergraph.Apollo.Configuration.Actions.ApolloConfigurationAction - Service is in state: Stopped
2017-07-05 11:02:54,069 [7] DEBUG Intergraph.Apollo.Configuration.Actions.ApolloConfigurationAction - Service is already stopped
2017-07-05 11:02:54,071 [7] INFO  Intergraph.Apollo.Configuration.Actions.ApolloConfigurationAction - Registering application with Geospatial Welcome Page
2017-07-05 11:02:54,071 [7] INFO  Intergraph.Apollo.Configuration.Actions.ApolloConfigurationAction - Registering with GeoSpatial Welcome page
2017-07-05 11:02:54,071 [7] DEBUG Intergraph.Apollo.Configuration.Actions.ApolloConfigurationAction - Looking up product info using productId:{D775E102-F1C3-484B-B75B-CD37D5168A66}
2017-07-05 11:02:54,074 [7] DEBUG Intergraph.Apollo.Configuration.Actions.ApolloConfigurationAction - version=16.00.0000.01105
2017-07-05 11:02:54,074 [7] DEBUG Intergraph.Apollo.Configuration.Actions.ApolloConfigurationAction - product name:ERDAS APOLLO 2016
2017-07-05 11:02:54,074 [7] DEBUG Intergraph.Apollo.Configuration.Actions.ApolloConfigurationAction - installDate:2017-07-04
2017-07-05 11:02:54,074 [7] DEBUG Intergraph.Apollo.Configuration.Actions.ApolloConfigurationAction - app url=http://ServerName:80/erdas-apollo
2017-07-05 11:02:54,074 [7] FATAL Intergraph.Configuration.ConfigurationActionExecutor - Action type Intergraph.Apollo.Configuration.Actions.ApolloConfigurationAction threw exception
System.Xml.XmlException: Root element is missing.
   at System.Xml.XmlTextReaderImpl.ThrowWithoutLineInfo(String res)
   at System.Xml.XmlTextReaderImpl.ParseDocumentContent()
   at System.Xml.Linq.XDocument.Load(XmlReader reader, LoadOptions options)
   at System.Xml.Linq.XDocument.Load(String uri, LoadOptions options)
   at Intergraph.GeoSpatialWelcome.Configuration.ServerApplicationRegistry.UpdateApplication(String appName, String appUrl, String version, String creationDate, String updateDate)
   at Intergraph.Apollo.Configuration.Actions.ApolloConfigurationAction.RegisterGeoSpatialWelcome()
   at Intergraph.Apollo.Configuration.Actions.ApolloConfigurationAction.Execute(CancellationToken token)
   at Intergraph.Configuration.ActionExecutor.ExecuteInternal(CancellationToken token)
2017-07-05 11:02:54,074 [7] INFO  Intergraph.Configuration.ConfigurationActionExecutor - All actions executed successfully

 

 

 

APOLLO SmartSync and Tomcat services  are not starting...

 

 

Does someone have an idea what can be wrong?

 

Thanks in advance

Elodie

Technical Evangelist
Posts: 987
Registered: ‎07-30-2015

Re: ERDAS APOLLO 2016 update failed