APOLLO & ECW/JP2 Discussions

Wondering how others have configured their ERDAS APOLLO server or what data they are crawling? The ERDAS APOLLO Discussion board is a place to find information, share ideas and more. Join the community, connect, contribute and share.
Showing results for 
Search instead for 
Do you mean 
Occasional Contributor
Posts: 14
Registered: ‎11-18-2015

Ergas Apollo Essentials send FATAL error.

2016-10-12 16:53:23:996 [78472] FATAL com.erdas.ecwsdk.util - (thread) ECW Version : 5,2,1,309
 Unknown Error:
An error has occured in this application.  If you receive this message,
please report it to Hexagon Geospatial Support to assist with fixing this error.

An Access Violation Exception occurred at code address 0x7fedaa25100 attempting to
WRITE to memory address 0x7fedaa25100.

Dump: N/A

Stack Trace:
Function: CS::HttpResponse::GetHttpResponseCode
File: C:\Program Files\Hexagon\ERDAS APOLLO\bin\NCSEcw.dll
RVA: 00006196 HINSTANCE: 034F0000 BP: 27994B00
Dump: 85c00f455c24408bc34883c4305bc3cccccccccccccccccccccc40534883ec30

Function: NCSTinyXmlAuthRequest:Smiley FrustratedendXMLHTTPRequest
File: \\?\C:\Program Files\Hexagon\ERDAS APOLLO\bin\NCSSUtil.dll
RVA: 002D9728 HINSTANCE: D3690000 BP: 27994CE0
Dump: 890641b6013dc80000007554488bcfe87894110085c0744e33d28bc8e81b8d11

Function: NCSTinyXmlAuthRequest:Smiley FrustratedendRequestEx
File: \\?\C:\Program Files\Hexagon\ERDAS APOLLO\bin\NCSSUtil.dll
RVA: 002D8A9D HINSTANCE: D3690000 BP: 27994CE8
Dump: 84c00f94c3488d8df0030000ff15c1dc270084db0f84b1000000488d15caa12a

Occasional Contributor
Posts: 14
Registered: ‎11-18-2015

Re: Ergas Apollo Essentials send FATAL error.

someone has experienced the same error on IWS.log file?, I can´t use any WMS services!

Frequent Contributor
Posts: 150
Registered: ‎04-29-2016

Re: Ergas Apollo Essentials send FATAL error.

Hello enmartin,


Have you solved this problem as i have the same issue with Apollo Essentials at both wms, wmts




Maha Kamal
Posts: 138
Registered: ‎05-31-2016

Re: Ergas Apollo Essentials send FATAL error.

[ Edited ]

This is probably caused by a corrupt image.



You may be able to figure out which image is causing the problem by changing the logging level to debug and restarting IIS.

Then the next time you have this problem you should be able to see which images Apollo is accessing.

Once you know which images Apollo is using you can use ECWCheck.exe to validate your image files.

ECWCheck.exe is available here https://download.hexagongeospatial.com/downloads/apollo/erdas-apollo-utilities-2016


If you are not able to determine which image is causing the problem, open a support ticket and attach the log file and the crash dumps for the developers to have a look at.


Crashdumps are here C:\Program Files\Hexagon\ERDAS APOLLO\log\crashdumps