APOLLO & ECW/JP2 Discussions

Wondering how others have configured their ERDAS APOLLO server or what data they are crawling? The ERDAS APOLLO Discussion board is a place to find information, share ideas and more. Join the community, connect, contribute and share.
Showing results for 
Search instead for 
Do you mean 
Occasional Contributor
Posts: 15
Registered: ‎12-08-2015

Problem with Chinese path of lidar dataset

I try to crawler some lidar data with apollo, all of them are store in a directory which name is Chinese.


The crawler job does not show any error. But when I check the file in DM, I found that the thumbnail is unavailable. And I can not see the data in portal.


But when I copy it to a new path without Chinese,everything is good.


Is that means the APOLLO does not support Lidar data in Chinese path?


BTW, image file (img/tif/ecw) is good in Chinese path.

Technical Evangelist
Posts: 922
Registered: ‎07-30-2015

Re: Problem with Chinese path of lidar dataset


It looks like Apollo could not crawl any path with chinese characters.

Do you mean this issue only happen to Lidar data? no similar issue with other datatypes (e.g., img, ecw)?




Occasional Contributor
Posts: 15
Registered: ‎12-08-2015

Re: Problem with Chinese path of lidar dataset

Lidar(.las) and the vector data(.shp) do not support any chinese characters.

But the image data(eg.,.img.tif.ecw) and the business data(eg.,.pdf.docx) can be crawled either in a path with chinese characters or with a chinese file name.


About the Lidar data, I notice that the apollo will transform the las file to hpc file automatically. So I did a little test like this:

  1. Copy one LAS file to an all english path, crawl it with DM, everthing is good. Then I copy the HPC file which is transformed by APOLLO from ..\storage\pointcloud\hpc, and put it into a path with chinese characters, I also copy it to another one and change its name to chinese.Then I crawl them with DM, everthing is good.1.jpg

2. So I guess there is something wrong with APOLLO when it tried to transform the LAS to HPC, it seems like the transform process does not support chinese characters.

3.I tried to did the transform manually with ERDAS IMAGINE 2016 and GeoCompressor 2016, I met the same problem.




Can anyone help me solve this problem?