APOLLO & ECW/JP2 Discussions

Wondering how others have configured their ERDAS APOLLO server or what data they are crawling? The ERDAS APOLLO Discussion board is a place to find information, share ideas and more. Join the community, connect, contribute and share.
Showing results for 
Search instead for 
Do you mean 
Posts: 100
Registered: ‎02-10-2017

Service Temporarily Unavailable!

[ Edited ]



I'm new working with APOLLO and for the first time I've tried to install Apollo 2016 following the documentation available in:




I didn't get any error on the installation but when accessing the Portal it gives error on https://lis-sgiv-apollo/erdas-apollo/vector/WORLDWIDE WMS:



Service Temporarily Unavailable!
The server is temporarily unable to service your request due to maintenance downtime or capacity problems. Please try again later.




When checking the errors in log file for tomcat-redirector I the the following messages:


[Thu Feb 01 16:22:30.687 2018] [3196:4684] [error] ajp_send_request::jk_ajp_common.c (1728): (node1) connecting to backend failed. Tomcat is probably not started or is listening on the wrong port (errno=61)
[Thu Feb 01 16:22:31.792 2018] [3196:4684] [error] ajp_send_request::jk_ajp_common.c (1728): (node1) connecting to backend failed. Tomcat is probably not started or is listening on the wrong port (errno=61)
[Thu Feb 01 16:22:31.799 2018] [3196:4684] [error] ajp_service::jk_ajp_common.c (2799): (node1) connecting to tomcat failed (rc=-3, errors=266, client_errors=0).
[Thu Feb 01 16:22:31.910 2018] [3196:4684] [error] service::jk_lb_worker.c (1675): All tomcat instances failed, no more workers left
[Thu Feb 01 16:22:31.912 2018] [3196:4684] [error] HttpExtensionProc::jk_isapi_plugin.c (2240): service() failed with http error  


The smartsync.log is also giving me the same message:

Error connecting to Apollo server: https://lis-sgiv-apollo@port:443


By the way, when I tried to run the service ERDAS APOLLO Tomcat Application Server, it was giving me an error message "File could not be found". 

When configuring the ReservedPorts for Tomcat to try to overcome my error, the way that is described in the Troubleshooting section on the documentation, I noticed that in the Windows Registry key 





the value that was present was

C:\Program Files\Hexagon\ERDAS APOLLO\tomcat\bin\tomcat7.exe" //RS//APOLLOTOMCAT7

I went to the directory specifed in the ImagePath and there was no tomcat7. It was tomcat8.exe.

I changed to the correct value and afterwards it the service started to run properly.


Anyone can help with this?

Posts: 138
Registered: ‎05-31-2016

Re: Service Temporarily Unavailable!

[ Edited ]

I just read your post again and realised that I do the same thing to get 2016 Apollo running after installing SP3.

I have not found this issue documented anywhere, but after changing the registry entry to use Tomcat8.exe instead of Tomcat7.exe it works for me.



I have just had a look in the install logs and the problem is being caused by the installer using the wrong name ( APOLLOTOMCAT7 ) for the Apollo Tomcat service.

Running the following 2 commands should fix the problem. You should check the current name of your Apollo Tomcat Service before running the uninstall command.


C:\>"C:\Program Files\Hexagon\ERDAS APOLLO\tomcat\bin\apolloservice.bat" uninstall APOLLOTOMCAT

C:\>"C:\Program Files\Hexagon\ERDAS APOLLO\tomcat\bin\apolloservice.bat" install APOLLOTOMCAT



I believe the the change to the registry should do the same thing.

After making the registry change does your Apollo server work as expected?





Posts: 100
Registered: ‎02-10-2017

Re: Service Temporarily Unavailable!

Hi Phil.


Sorry for the late response.

To overcome my problem I've created a new VM and installed the SW again.

This time it seems to be working.

The stange thing was that I've followed the same instructions and in the new installation I didn't need to update the registry because the installation has done that.

I must have done something wrong the first time.


Best regards.