Showing results for 
Search instead for 
Do you mean 

64bit AdoptOpenJDK 11 for Apollo 2020

by Technical Evangelist ‎03-16-2020 05:08 PM - edited ‎10-16-2020 06:56 AM (624 Views)

64bit Version 11 of the Java JDK (Java Software Development Kit) is required for Apollo 2020 (64bit Version 8 of the Java JDK is required for Apollo 2018).

 

In 2018 Oracle announced that major changes to Java Virtual Machine with regard to pricing and packaging would take effect with the release of Java 11. With the Java 11 release, there will no longer be a free version of the Oracle Java Runtime available. All commercial customers will need to purchase a license from Oracle, either based on cores or per user via a monthly subscription.

 

For APOLLO users who do not wish to pay the Oracle subscription, the APOLLO configuration supports open versions of Java, such as OpenJDK or AdoptOpenJDK.

Whether you are using a licensed version of Java or an open version, you must do the following:

  • Set the JAVA_HOME system environment variable and associate it with the Java installation folder, such as C:\Program Files\Java\jdk-11.0.4.

  • Add the Java \bin location to your PATH environment variable and define it as %JAVA_HOME%\bin.

 

IMPORTANT NOTE FOR THOSE USING ERDAS APOLLO CORE CONSOLE

If you install Java via the Oracle, Amazon Corretto, OJDKBuild or AdoptOpenJDK installers, the registry entry required for the ERDAS APOLLO Core Console will be automatically generated. However, if you install Java by extracting a compressed file into a folder on disk, such as with OpenJDK, you will need to manually create the required registry entries. At runtime, ERDAS APOLLO Core Console looks for the string value JavaHome, whose value should be set to the path of the root folder of your java installation.

 

As needed, create the following registry key:

 

HKEY_LOCAL_MACHINE\SOFTWARE\JavaSoft\JDK\<JAVA-VERSION>

Add the following string value to the registry key:

 

JavaHome=<Java installation path>

 

For example:

 

HKEY_LOCAL_MACHINE\SOFTWARE\JavaSoft\JDK\11

JavaHome=”C:\Program Files\jdk-11.0.1\”

 

 

 

Install 64bit AdoptOpenJDK 11 for Apollo 2020

 

If user use 64bit AdoptOpenJDK 11, then user don't need to manually modify registry key and setup environment variables. AdoptOpenJDK installer will automatically setup both JAVA_HOME and registry keys. Just remember to check the last two options (i.e.,"Set JAVA_HOME variable", and "JavaSoft (Oracle) registry keys" :

 

Screenshot from 2020-03-16 19-02-42.png

 

NOTE: If you have 64bit Oracle Java 11 installed, please uninstall Oracle java before installing 64bit AdoptOpenJDK 11. Because Apollo tomcat service will not start properly (e.g., generate a lot of memory dump mdmp files inside tomcat folder) if you have two 64bit JVMs running at the same time. So make sure only have one 64bit JVM installed on Apollo server.

 

 

 

Also make sure Apollo tomcat JVM is using adoptOpenJDK.

Java Virtual Machine: C:\Program Files\AdoptOpenJDK\jdk-11.0.6.10-hotspot\\bin\server\jvm.dll

tomcat.jpg

Comments
by
on ‎04-03-2020 12:47 AM

Hi Haiyan, 

 

That was an useful info. I have tried with the Adoptopenjdk for Apollo 2020 configuration. I have got Adopt openjdk v11 from here https://adoptopenjdk.net/?variant=openjdk11&jvmVariant=hotspot 

 

After installed jdk, i have checked in cmd. Its working fine. All the "JAVA_HOME" variable path were set. 

 

Then after,  when I run Apollo configuration, I have got popup msg "64 bit java is not installed". I ignored and proceed with the configuration. Configuration was successful but ended with the tomcat server is not starting. 

 

Then, I have restarted the machine and start the tomcat server from local service. still, its not working. 

 

Am attaching the log file and error msg here.

 

Capture.JPG

 

https://drive.google.com/file/d/1fHba2ubJpSy1Rej9fRM_a_63N5fuVlf1/view?usp=sharing 

 

Pls take a look. 

 

Regards, 

Karthik. 

by Technical Evangelist
‎04-03-2020 06:49 AM - edited ‎04-03-2020 06:54 AM

Make sure to use 64bit Java.

Check tomcat's JVM, make sure it is using AdoptOpenJDK

by
on ‎04-06-2020 04:49 AM

Thanks haiyan. It was a JVM issue. Now Problem solved. 

Contributors