Showing results for 
Search instead for 
Do you mean 

Access WCS, WMS for individual dataset in Apollo catalog

by Technical Evangelist ‎02-23-2016 05:18 AM - edited ‎07-15-2020 07:10 AM (968 Views)

In order to allow WCS and WMS access to individual dataset in APOLLO catalog.

user need to modify the following file for "EXPOSURE" value.

$APOLLO_HOME\config\erdas-apollo\providers\coverage\providers.fac

or

$APOLLO_HOME\config\erdas-apollo\providers\coverage\im-providers.fac

 

<!-- This file is being included in a parent providers.fac -->
<CREATE ID="EAIM" JCLASS="com.ionicsoft.wmtmap.provider.coverage.HierarchicalProvider">
<PARAM NAME="SECURITYRESOLVER" VALUE="container"/>
<PARAM NAME="NODEEXCLUSION" VALUE="single"/>
<PARAM NAME="METADATATEMPLATEDATASETURL" VALUE="file:///C:/ERDAS/APOLLO2011_AT/config/erdas-apollo/providers/coverage/mdTemplDataset.xml"/>
<PARAM NAME="METADATATEMPLATEAGGREGATEURL" VALUE="file:///C:/ERDAS/APOLLO2011_AT/config/erdas-apollo/providers/coverage/mdTemplAggregate.xml"/>
<PARAM NAME="TMPPATH" VALUE="C:/ERDAS/APOLLO2011_AT/config/erdas-apollo/storage"/>
<PARAM NAME="ABSTRACT" VALUE="ERDAS Apollo Advantage default Coverage Provider "/>
<PARAM NAME="PYRAMIDDIR" VALUE="//ews64/APOLLO_2011_Storage/pyramid"/>
<PARAM NAME="VERYLARGETRIGGER" VALUE="2500"/>
<PARAM NAME="INDEXINGPROVIDER">file://localhost/C:/ERDAS/APOLLO2011_AT/config/erdas-apollo/providers/coverage/babel-application-context.xml</PARAM>
<PARAM NAME="MAXCACHE" VALUE="500"/>
<PARAM NAME="WMS_REPROJECTION_QUALITY" VALUE="75"/>
<PARAM NAME="SRS" VALUE="EPSG:4326"/>
<PARAM NAME="INDEXINGTYPE" VALUE="BABEL"/>
<PARAM NAME="NAME" VALUE="EAIM"/>
<PARAM NAME="OWSINFOURL" VALUE="file:///C:/ERDAS/APOLLO2011_AT/config/erdas-apollo/providers/coverage/eaim_md.xml"/>
<PARAM NAME="WCS_REPROJECTION_QUALITY" VALUE="75"/>
<PARAM NAME="EXPOSURE" VALUE="SHOW_AGGREGATES"/>

 

change from
<PARAM NAME="EXPOSURE" VALUE="SHOW_AGGREGATES"/>

to:

<PARAM NAME="EXPOSURE" VALUE="SHOW_ALL"/>

 

 

SHOW_ALL: show all coverage offerings in the Capabilities document SHOW_AGGREGATES: show only aggregates nodes (non-terminal coverage offerings), this has a meaning only with Hierarchichal providers (use only with Image Archive)

SHOW_NOTHING: Do not show any coverage offerings in the Capabilities document Default value is SHOW_ALL


The return may be very slow (if you have tons of aggregate and dataset) http://ews64.lggm.llc:8080/erdas-apollo/coverage/EAIM?REQUEST=GetCapabilities&SERVICE=WMS&VERSION=1....

Comments
by
on ‎11-04-2018 08:28 PM

Is it possible to do this but only expose a subset of the images to SHOW_ALL?

 

I have tried duplicating the EAIM service and changing the Root to one of the Aggregates under Root but I got some strange problems.

Does anyone know if something like this is possible?

by Technical Evangelist
on ‎11-05-2018 12:39 PM
Hi Philip,
 
I think the easiest way is to create service in Apollo essential, you can have WMS url for individual service inside Apollo essential. 
 
Or you can use data manager to define view service. In data manager, you can also disable/enable View Services for your aggregate and dataset. Right-click on aggregate/dataset, and check Property->View Services->WMS.
 
best
haiyan
by Moderator
on ‎11-08-2018 08:21 AM - last edited on ‎11-08-2018 08:23 AM by Community Manager

Hi Phil,

 

I don't think it is possible. You are not the first one to request that.

 

Maybe there is a possibility by creating a context service. You should create a context file and then use it to create a context service. Have you already tried that? An easy way to create create a Context file is to use the old style editor, add the layers and then save the Context.

 

Florent

by
on ‎12-20-2018 11:45 PM

Thanks Florent

I have not tried that before, I will give it a go.

 

 

by Moderator
on ‎12-21-2018 01:49 AM

But normaly, the use case of "subsetting" the catalog WMS service (EAIM or ApolloCatalogWMS) is to use the security: create different roles, etc.

Contributors