Developer Discussions

Discuss topics with other Hexagon Geospatial Power Portfolio developers and experts to get the most out of our products.
Showing results for 
Search instead for 
Do you mean 
Reply
Highlighted
Contributor
Posts: 47
Registered: ‎01-14-2016

Custom Feature Info command returns an error

[ Edited ]

Hello,

 

We created a custom command - a button in GUI Geospatial Portal 16.5.

When a user selects a feature on a map and activates this command, it returns a recordset from SAP for the selected feature.

In most cases, it works.

 

But sometimes the request to the properties of the selected feature on a map returns an error:

 

Compositor.WebClient.ashx?p=%2fNLMK_TEST%2fFull.aspx&e=en-US.release.js&t=637111633148129564:880

POST

http://nl-sd-gissrv01/NLMK_TEST/api/stateful/featureInfo

500 (MapServiceNotFoundException)

 

The screenshot is attached.

 

Part of our script:

 

$GP.map.featureInfo({preventDefaults: true}, function (result) { });

 

 

Could anyone assist us to resolve this issue? The question is rather urgent and boring. 

 

 

Many thanks,

Kirill

Highlighted
Technical Evangelist
Posts: 1,225
Registered: ‎09-11-2015

Re: Custom Feature Info command returns an error

Hi Kirill,

 

It could be that the session expired and then Portal couldn't find the supplied MapServiceId. DEBUG Portal log could help investigating the issue - try to find the failed request there and what preceded it.

 

 

Jan Neumann
Post Sales Engineer Web Applications
Hexagon Geospatial