Developer Discussions

Discuss topics with other Hexagon Geospatial Power Portfolio developers and experts to get the most out of our products.
Showing results for 
Search instead for 
Do you mean 
Reply
Highlighted
Regular Contributor
Posts: 253
Registered: ‎05-01-2016
Accepted Solution

GeoSpatial Portal SDK 2016 ep01 - missing files?

Does the zip fle for the 2016 GeoSpatial Portal SDK ep01 that is downloaded provide all needed files when unzipped?

I am finding that i am missing the PortalSDKApplication.sln file in the /src folder for example.  It is included with the 2016 GeoSpatial Portal SDK (non ep01 version)

Highlighted
Technical Evangelist
Posts: 132
Registered: ‎08-05-2015

Re: GeoSpatial Portal SDK 2016 ep01 - missing files?

I've double checked this with the EP01 SDK downloaded from the location pointed by this article:

http://community.hexagongeospatial.com/t5/SDK-API/Geospatial-Portal-SDK-2016-EP01/ta-p/10162

 

I've downloaded the package, unzipped it and then I've verified that the PortalSDKApplication.sln is present in the portal-sdk-application-ep-portal-sdk-package.zip in the src folder.

 

There are several zip files - are you using portal-sdk-application-ep-portal-sdk-package.zip ?

Highlighted
Regular Contributor
Posts: 253
Registered: ‎05-01-2016

Re: GeoSpatial Portal SDK 2016 ep01 - missing files?

I downloaded it again and unzipped and i do have all the needed files.  Thanks.  But now i have a new problem i haven't had before.  The cache folder under app_data is not being created when i build the application so when i go to the webpage it says it can't access files in that app_data  cache folder  

Any idea what might cause that?

thanks again...

Highlighted
Regular Contributor
Posts: 253
Registered: ‎05-01-2016

Re: GeoSpatial Portal SDK 2016 ep01 - missing files?

[UnauthorizedAccessException: Access to the path 'C:\inetpub\wwwroot\SDK2016\src\Application\App_Data\Cache\SDK2016' is denied.]
   System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath) +216
   System.IO.Directory.InternalCreateDirectory(String fullPath, String path, Object dirSecurityObj, Boolean checkHost) +1562
   System.IO.Directory.InternalCreateDirectoryHelper(String path, Boolean checkHost) +216
   Intergraph.WebSolutions.Core.WebClient.Platform.Web.CssCompositor.SaveCss() +384
   Intergraph.WebSolutions.Core.WebClient.Platform.Web.CssCompositor.SetUpCss() +318
   System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +4628
Highlighted
Regular Contributor
Posts: 253
Registered: ‎05-01-2016

UPDATE>>Progress - ep01 working but.... still no pins!!!

[ Edited ]

I made a copy of my application folder and tried building again and got the Cache folder and files in it in the app_data folder!

Not sure why but it worked fine...

But now if i go to examplesess.aspx and try the fancy tool tip example all goes fine with zoom to United States but still no pins displaying - that is the orignal problem i had before realizing i needed to upgrade to the proper SDK version matching my geomedia webmap ep01

 

Ok i tried it on a machine with geospatial portal and the pins only work for examples aspx and NOT for examplesess.aspx so that explains that but can i get it to work with examplesess.aspx without having geospatial portal installed?   I guess i need help with adding the styles for the pins...but is that all that is missing?

Highlighted
Technical Evangelist
Posts: 1,236
Registered: ‎09-11-2015

Re: UPDATE>>Progress - ep01 working but.... still no pins!!!

The original topic looks resolved. The discussion regarding pins can continue in its own thread:

http://community.hexagongeospatial.com/t5/Developer-Discussions/Fancy-Tooltips-example-and-wc-map-la...

Jan Neumann
Post Sales Engineer Web Applications
Hexagon Geospatial