Hexagon Geospatial
MENU

Developer Discussions

Discuss topics with other Hexagon Geospatial Power Portfolio developers and experts to get the most out of our products.
Showing results for 
Search instead for 
Do you mean 
Reply
New Contributor
Posts: 2
Registered: ‎05-22-2018
Accepted Solution

Java Virtual Machine Launcher error in GMSC 16.5.316.4

Hi, 

 

I have this error when I want to run a project in java via Eclipse : 

 

javaError.PNG

javaError2.PNG

 

Exception in thread "main" java.lang.UnsupportedClassVersionError: com/intergraph/web/SmartClient has been compiled by a more recent version of the Java Runtime (class file version 53.0), this version of the Java Runtime only recognizes class file versions up to 52.0
	at java.lang.ClassLoader.defineClass1(Native Method)
	at java.lang.ClassLoader.defineClass(Unknown Source)
	at java.security.SecureClassLoader.defineClass(Unknown Source)
	at java.net.URLClassLoader.defineClass(Unknown Source)
	at java.net.URLClassLoader.access$100(Unknown Source)
	at java.net.URLClassLoader$1.run(Unknown Source)
	at java.net.URLClassLoader$1.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.net.URLClassLoader.findClass(Unknown Source)
	at java.lang.ClassLoader.loadClass(Unknown Source)
	at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)
	at java.lang.ClassLoader.loadClass(Unknown Source)
	at sun.launcher.LauncherHelper.checkAndLoadMain(Unknown Source)

 

GMSC version : 16.5.316.4 

 

The run configuration that I use is the same as a working project in an older version of GMSC

 

Thanks, 

 

Romain

 

 

Highlighted
Frequent Contributor
Posts: 113
Registered: ‎04-05-2016

Re: Java Virtual Machine Launcher error in GMSC 16.5.316.4

Hi Romain,

 

you need to reference a JDK version to your project that is of version 11 or newer.

 

Regards,

Sven

Do you need immediate support?
Please submit a Ticket through our
Development Ticket Portal.