Hexagon Geospatial
MENU

ERDAS APOLLO & ECW/JP2

Wondering how others have configured their ERDAS APOLLO server or what data they are crawling? The ERDAS APOLLO Discussion board is a place to find information, share ideas and more. Join the community, connect, contribute and share.
Showing results for 
Search instead for 
Do you mean 
Reply
Occasional Contributor
Posts: 13
Registered: ‎10-18-2017
Accepted Solution

Error while configuring ERDAS APOLLO 2018

Hi all,

 

After running the configuration wizard for ERDAS APOLLO 2018, it is displaying an error: A batch process returned an unexpected exit code.

 

While studying the config log files, it showed Java related issue. I had installed JDK, registered the same in environment system variable and checked the java version in command prompt it showed 

 

java version "1.8.0_191"
Java(TM) SE Runtime Environment (build 1.8.0_191-b12)
Java HotSpot(TM) 64-Bit Server VM (build 25.191-b12, mixed mode)

 

I have also attached the logfile. ERDAS APOLLO service is also not formed in services.

 

Thanks for help in advance.

 

Aroop

Technical Evangelist
Posts: 821
Registered: ‎07-30-2015

Re: Error while configuring ERDAS APOLLO 2018

Can you install latest JRE 8 (not JDK 8), and give a try again?

 

best

haiyan

Highlighted
Occasional Contributor
Posts: 13
Registered: ‎10-18-2017

Re: Error while configuring ERDAS APOLLO 2018

Hi,

 

Thanks for your reply. I configured another system with the following details at client end:

 

OS: Windows 8.1

Microsoft .net Framework : 4.6

PostGres: 9.5

PostGIs: 2.5

Java SDK: 8 Update 191

 

The problem again resurfaced. Before configuration process, I checked, whether it had formed the ERDAS APOLLO TOMCAT service. It didn't show in the services list. So, I used the following command to create the service manually:

 

"C:\Program Files\Hexagon\ERDAS APOLLO\tomcat\bin\apolloservice.bat" install APOLLOTOMCAT

 

It created the service, but noted that JAVA_HOME is not set. Hence, I tried to run and check the following command:

cd C:\Program Files\Hexagon\ERDAS APOLLO\tomcat\bin

and ran startup.bat.

It gave error stating neither JAVA_HOME nor JRE_HOME set. Set environment variable. I tried to set the environment variable JAVA_HOME = c:\Program Files\Java\jdk1.8.0_191

Still error remained same...but it was resolved by setting the environment variable as below:

JAVA_HOME = C:\Program Files\Java\jdk1.8.0_191\

Then ran startup.bat command and JAVA was registered successfully for CATALINA_HOME.

 

Thank You.

vip
Staff
Posts: 11
Registered: ‎07-13-2017

Re: Error while configuring ERDAS APOLLO 2018

Hi,

 

Instead of creating environment variable  JAVA_HOME = C:\Program Files\Java\jdk1.8.0_191\ . Update the Apollo Version to 

16.05.01.00119 . Restart the Machine then it's working fine!!

 

Try this solution and it works better..

 

Regards

VIPALW KUMAR P

Polls
Please register to vote
Do you need immediate support?
If you encounter a critical issue and need immediate assistance please submit a Service Request through our Support Portal.