Hexagon Geospatial
MENU

ERDAS APOLLO & ECW/JP2

Wondering how others have configured their ERDAS APOLLO server or what data they are crawling? The ERDAS APOLLO Discussion board is a place to find information, share ideas and more. Join the community, connect, contribute and share.
Showing results for 
Search instead for 
Do you mean 
Reply
Frequent Contributor
Posts: 147
Registered: ‎03-04-2016
Accepted Solution

Re: Setup Apollo 2018 with public-facing server name and https/SSL

[ Edited ]

Hello guys,

I've installed Apollo 2018 update 4 (WS2016, PostgrSQL/PostGIS 9.4) and done everything explained here to enable SSL but io keep getting an error when i try to access erdas-apollo page or the catalog itself. 

I've been able to do the SSL before and it worked. Tomcat log does not say anything after the 404 error messages happen.

Of course, Tomcat service and Geospatial Admin service are up.

Here are the errors:

On https://apollo.geosystems.fr/erdas-apollo

SSL_error_edas-apollo.JPG

In Data Manager when trying to connect to catalog

SSL_error_dm-connexion.JPG

 

In portal (as you can see, i activated the alias)

SSL_error_portal.JPG

 

What am i possibily missing?

Elodie

Moderator
Moderator
Posts: 341
Registered: ‎11-16-2015

Re: Setup Apollo 2018 with public-facing server name and https/SSL

Bonjour Elodie,

 

Have you checked if you can access APOLLO on localhost? I mean to be sure this is not a proxy issue.

 

Frequent Contributor
Posts: 147
Registered: ‎03-04-2016

Re: Setup Apollo 2018 with public-facing server name and https/SSL

It should'nt be proxy issue because i don't have proxy that network. it's a remote server in OVH network.

 

With that said, localhost don't work for the catalog (in http because https is only avaible for my domain).

I didn't block the 80 port yet

SSL_error_dm-connexion-localhost.JPG

I can access adminportal in localhost but not the erdas-apollo page

SSL-error-localhost-admin.JPG

 

SSL_error_edas-apollo_localhost.JPG

 

Highlighted
Moderator
Moderator
Posts: 341
Registered: ‎11-16-2015

Re: Setup Apollo 2018 with public-facing server name and https/SSL

Have you enabled CORS during the configuration?

The last versions of Tomcat include stronger enforcement of CORS security standards, including one that forbids “Origin:” to be set to “*” while “Credentials: true”. As such, it is no longer possible to have credentials enabled and use the wildcard Origin header simultaneously. (copying documentation)

Frequent Contributor
Posts: 147
Registered: ‎03-04-2016

Re: Setup Apollo 2018 with public-facing server name and https/SSL

[ Edited ]

Thanks Florent,

I missed that in the documentation.

Actually i have enable the CORS option.

Based on this new inforamtion, I disabled it and i was able to access my portal in https as well as the catalog via the portal, and the data manager also.

 

Another thing though:

I've installed jdk 8u172 in 32 and 64 bits, set JAVA_HOME and even JRE_HOME.

And in configwizard log i had this

 

Installing the service 'APOLLOTOMCAT' ...
Using CATALINA_HOME: "C:\Program Files\Hexagon\ERDAS APOLLO\tomcat"
Using CATALINA_BASE: "C:\Program Files\Hexagon\ERDAS APOLLO\tomcat"
Using JAVA_HOME: "C:\Program Files\Java\jdk1.8.0_172"
Using JRE_HOME: "C:\Program Files\Java\jdk1.8.0_172\jre"
Using JVM: "C:\Program Files\Java\jdk1.8.0_172\jre\bin\server\jvm.dll"
The service 'APOLLOTOMCAT' has been installed.

Why do we still have the 64 bits error at the launch of configwizard?

It exactly says: "64-bit Java is not installed. Please refer to the installation guide for product requisites.

 

 

Kind regards

Elodie

Do you need immediate support?
If you encounter a critical issue and need immediate assistance please submit a Service Request through our Support Portal.