Hexagon Geospatial
MENU

ERDAS IMAGINE Q&A

ERDAS IMAGINE, the world’s leading geospatial data authoring system, supplies tools for all your Remote Sensing and Photogrammetry needs.
Showing results for 
Search instead for 
Do you mean 

Importing SAfA project results in large Y-parallax if system’s decimal symbol is a comma

by YaseminS. on ‎11-07-2017 09:59 AM (689 Views)

Question

After importing an INPHO MATCH-AT *.prj project file into Stereo Analyst for ArcGIS using the project importer a big y-parallax is observed with all stereo models after loading image pairs into the stereo window. How can this be corrected?

 

Computer's Region and language setting: German

Software: ERDAS Extensions 2016 SP2 for ArcGIS 10.5

Answer

The root cause of the problem is that an INPHO project uses the English number format when storing the data while the function used to read the numbers is based on the number format of the computer. If the default number decimal symbol is set to be a comma, please follow the steps outlined below to import the images correctly.

 

1. Open the computer’s Region and Language settings dialog (Control Panel > Regoin and Language).

2. Change the Format to English.

 

Format.jpg

 

3. Click the Additional Settings button.

4. In the Customize Format dialog window enter a period “.” for the Decimal Symbol and enter a comma “,” for the Digit Grouping Symbol.

5. Click OK to close the Customize Format dialog and click OK in the Region and Language dialog to apply the settings.

 

Numbers.jpg

 

6. Restart ArcMap and load the INPHO project. The large y-parallax issue should be gone.

 

This issue is fixed for the next major release of ERDAS Extensions 2018 for ArcGIS 10.5.1. Users will no longer be required to change their system’s region & language settings.

 

Contributors