Hexagon Geospatial
MENU

ERDAS IMAGINE Q&A

ERDAS IMAGINE, the world’s leading geospatial data authoring system, supplies tools for all your Remote Sensing and Photogrammetry needs.
Showing results for 
Search instead for 
Do you mean 

Landsat-8 data from USGS fails to import.

by sbent on ‎06-06-2017 05:57 PM (3,818 Views)

Question

When attempting to import Landsat-8 data downloaded from the USGS it fails with the error “The given input file is not in the USGS format”. Is it possible to use this data in ERDAS IMAGINE?

Answer

The USGS altered the naming format of their *.tar.gz zipped compressed files, using the product ID instead of the scene ID for the filename. This causes a problem with the Landat-8 from USGS importer which expects the filename to use the scene ID.

 

The solution is to change the name of the *.tar.gz file to match the scene ID. Open the scene’s metadata file and look for the LANDSAT_SCENE_ID number and use this as the filename. For example, the downloaded file “LC08_L1TP_037025_20170325_20170329_01_T1.tar.gz” should be renamed to “LC80370252017084LGN00.tar.gz”.

 

Another option is to manually extract the TIFF files from the *.tar.gz file using a program like WinRAR or WinZIP. Then display the individual TIFF files as a virtual stack in a 2D View or use the Layer Stack tool to combine the TIFF files for each band into a multi-layer image. 

 

Comments
by DoRisHe
on ‎07-17-2017 05:09 AM

Thanks, Stephen!

Just bumped into this problem and directly solved it with your workaround.

by kansy
on ‎10-04-2017 03:40 AM

Hallo,

 

 

Partially, I am facimg a similar problem

 


I am using the import manager in ERDAS 16.0 to import Landsat Level 1 Tier 1 collection scenes


Due to  the new naming convention in Landsat, I had to replace the Landsat Product ID using the Landsat Scene ID for each image and by so doing I was able to import ( using the Import Manager) my scenes of choice.

Unfortunately, I am not able to import scences with suffix SG100 using the ERDAS IMAGINE Import manager,  . The import works when the scene ID ending with suffix ASN00

    LANDSAT_SCENE_ID = "LE71880542016364ASN00"
    LANDSAT_PRODUCT_ID = "LE07_L1TP_188054_20161229_20170219_01_T1"
 

LANDSAT_SCENE_ID = "LE71880542017014SG100"
    LANDSAT_PRODUCT_ID = "LE07_L1TP_188054_20170114_20170209_01_T1"
 

Please  any clues on what to do or circumvent this?

 Thanks

 Kansy

Contributors