Hexagon Geospatial
MENU

ERDAS IMAGINE

Discuss and share topics of interest using ERDAS IMAGINE the world’s leading geospatial data authoring system.
Showing results for 
Search instead for 
Do you mean 
Reply
New Contributor
Posts: 4
Registered: ‎03-15-2018
Accepted Solution

Help with Image display / histogram of skewed Float data

[ Edited ]

Hello everyone, I'm new, I just registered in this community. I have a problem with a picture of ERDAS, I made a model Maker, but in the result I get a completely gray image and not the relief of the Earth, someone has an idea how I can solve this. Thank you.

 

gray.JPGmetadata.JPG

Technical Evangelist
Posts: 731
Registered: ‎10-01-2015

Re: Help with Image

Hello,

 

I think you first thing you have to ask yourself is why you have a huge negative value (-48322) in a dataset that's supposed to be a relief dataset. Is it supposed to be a NoData value? Is it an isolated value, or are there other large negative values distributed through the data? 

 

If it's supposed to represent NoData you could recalculate statistics ignoring that value. Or you could set that value as NoData (and then recalculate stats).

 

But if you have other very large negative values beside -48322 then the problem is probably that you have Float data with a HUGE data range. Float data has the unique characteristic of needing to have its statistics calculations linearly binned (it cannot be Direct binned due to he nature of floating point values). So it's highly possible you have a massively skewed histogram with the majority of your data at one end and the linear binning (form min value to max value) cant; assign sufficient bins to show contrast in the "real data". 

 

If your data really is this way then you will need to alter the Preferences > File Format > Image Files (General) > Number of bins for floating point data preference value to something more appropriate to the range you have. The default is 32768. Try doubling it then recalculating statistics and see if the image looks any better. 

 

But it'd be simpler if -48322 is just an isolated NoData value that could be ignored in stats.

 

Cheers

Ian Anderson
Chief Product Owner, Desktop Remote Sensing
Hexagon Geospatial
New Contributor
Posts: 4
Registered: ‎03-15-2018

Re: Help with Image

Thanks Ian, I did not know the bins, in the Preferences window I have not known which number to change

 

 

However, in the option of recalculating statistics I have seen that the option linear Bin function gives me the option to change the value of #bins, I have changed and I put a very large number: 500 000, and now the image is displayed. However it still appears-48322, I guess that value never leaves the metadata, right?preferences.JPG

 

 
bins.JPG

 

Technical Evangelist
Posts: 731
Registered: ‎10-01-2015

Re: Help with Image

Looks like you're running an old version of ERDAS IMAGINE which doesn't have that Preference.

 

Yes - if you did not select to Ignore -48322 (or set it to NoData using the Set/Clear NoData Value option)) when you calculated the stats it will still be included. 

 

But obviously the number of bins was the cause of the visual problem.

 

Cheers

 

Ian

Ian Anderson
Chief Product Owner, Desktop Remote Sensing
Hexagon Geospatial
Do you need immediate support?
If you encounter a critical issue and need immediate assistance please submit a Service Request through our Support Portal.