Hexagon Geospatial
MENU

ERDAS IMAGINE

Discuss and share topics of interest using ERDAS IMAGINE the world’s leading geospatial data authoring system.
Showing results for 
Search instead for 
Do you mean 
Reply
Highlighted
Contributor
Posts: 36
Registered: ‎05-02-2018

Imagine photogrammetry SGM error

[ Edited ]

Hi everyone,

I buy an add-on licenses to use the SGM tool on a photogrammetric project but when I'm running the process, it failed immediately. I installed the update of Imagine.

Here is the error I got on the logfile :

01/08/18 12:11:15 TridiconSGMUTIL: Message:: Method not found: 'Int32 System.Environment.get_CurrentManagedThreadId()'.
01/08/18 12:11:15 SessionMgr(5948): TridiconSGMUTIL.exe exited with status 2.
01/08/18 12:11:15 SessionMgr(5948):  exited normally.

 

 

Do you have any idea to fix this problem ?
Thank's in advance.

Staff
Posts: 130
Registered: ‎06-30-2016

Re: Imagine photogrammetry SGM error

[ Edited ]

please provide more details such as sensor type of the project, image formats and image sizes...

 

Regards, Sam

Contributor
Posts: 36
Registered: ‎05-02-2018

Re: Imagine photogrammetry SGM error

I have 12 Tri-Stereo Pleiades images and I want to build a mosaic DSM with all the images contained in a block. The size of each images is approximately 40000x40000 px.

To test the SGM tool I used only 2 images of a Tri-Stereo. I'm making this test just to know if everything working (I got some problems with the licences few weeks before), but SGM isn't running without failing.

Staff
Posts: 130
Registered: ‎06-30-2016

Re: Imagine photogrammetry SGM error

Is the failure occuring when it is generating epipolar images?

Contributor
Posts: 36
Registered: ‎05-02-2018

Re: Imagine photogrammetry SGM error

No, the failure is after this step, when I click on "run" on the SGM window.

Staff
Posts: 130
Registered: ‎06-30-2016

Re: Imagine photogrammetry SGM error

Go to the output directory where the epipolar images are stored. Check if they are generated and also open them in IMAGINE viewer to see they are of expected quality (compare them with the original images)

Contributor
Posts: 36
Registered: ‎05-02-2018

Re: Imagine photogrammetry SGM error

I clean the SGM directory and recalculate the epipolar files.

Project name: teest.blk

Workdirectory: test


Here is the files inside the SGM directory :

teest.blk.bcf
teest.blk.bls
teest_0_1_m.aux
teest_0_1_m.rrd
teest_0_1_m.tif
teest_0_1_m.tif.gori
teest_0_1_m_rpc.txt
teest_0_1_p.aux
teest_0_1_p.rrd
teest_0_1_p.tif
teest_0_1_p.tif.gori
teest_0_1_p_rpc.txt
teest_0_1_report.txt

 

 

When I opened the tif file on imagine, the images are the same than original.

Staff
Posts: 130
Registered: ‎06-30-2016

Re: Imagine photogrammetry SGM error

The folder should have had two more files.

 

teest_0_1_m.pyr 

teest_0_1_p.pyr

 

These are pyramid layers for the Tiff files. SGM does not use the rrd format pyramid files and are not generated during epipolar image generation. I assume the rrd files got generated when you were displaying the epipolar images in the viewer.

 

Without these pyr files, SGM will fail. Have you been able to run SGM with other dataset on this machine?

 

Regards, Sam

Contributor
Posts: 36
Registered: ‎05-02-2018

Re: Imagine photogrammetry SGM error

[ Edited ]

Yes, the .rrd files were created when I opened the tif file.

Actually, when I calculate the needed files on the SGM module (i.e., epipolar image) I can see a progress bar with "epipolar image" written on it. But there is no epipolar files created.

Here, I use only 2 of 3 images from a Tri-Stereo acquisition. I also try with the 3 images but it also failed.
It's the first time I'm trying to use SGM module (we acquired the licenses few weeks ago) and I didn't find any tutorial about this module on Imagine 2018. So maybe I'm wrong on the process ?

I use :

New photogrammetric project with RPC sensor

Add the DIM files from the Pleiades Images, as Images

I then, compute the interior orientation from the DIM files.

Automatic point measurement (to get tie points)

Block Triangulation

SGM Module, first I compute the needed files for the images with "Not Ready" status (Epipolar calcul)

Then, I click on "run now" on the SGM Module window.

Am I right with the method ?

 

Thank's for your help !

Contributor
Posts: 36
Registered: ‎05-02-2018

Re: Imagine photogrammetry SGM error

Yes, the .rrd files were created when I opened the tif file.
 
Actually, when I calculate the needed files on the SGM module (i.e., epipolar image) I can see a progress bar with "epipolar image" written on it. But there is no epipolar files created.
 
Here, I use only 2 of 3 images from a Tri-Stereo acquisition. I also try with the 3 images but it also failed.
It's the first time I'm trying to use SGM module (we acquired the licenses few weeks ago) and I didn't find any tutorial about this module on Imagine 2018. So maybe I'm wrong on the process ?
 
I use :
 
New photogrammetric project with RPC sensor
Add the DIM files from the Pleiades Images, as Images
I then, compute the interior orientation from the DIM files.
Automatic point measurement (to get tie points)
Block Triangulation
SGM Module, first I compute the needed files for the images with "Not Ready" status (Epipolar calcul)
Then, I click on "run now" on the SGM Module


Am I right with the method ?
 
 
Thank's for your help !

Do you need immediate support?
If you encounter a critical issue and need immediate assistance please submit a Service Request through our Support Portal.