Hexagon Geospatial
MENU

ERDAS IMAGINE

Discuss and share topics of interest using ERDAS IMAGINE the world’s leading geospatial data authoring system.
Showing results for 
Search instead for 
Do you mean 
Reply
Occasional Contributor
Posts: 6
Registered: ‎10-01-2018

attribute table

Hello,

 

When I load a raster Tiff image (with Pseudo color), and try to open the attribute table, an error pops up saying "No raster attribute table. Compute stats on layer using image info." even though the layer definetly has attribute table with different classes in it. Can anybody please tell me what is going on here? this happens 80% of the time when I try to open the image and suddenly some times the attribute table shows up. I am not sure what is causing the problem. 

Any help will be greatly appreciated. 

 

Thanks,

 

Staff
Posts: 590
Registered: ‎02-02-2016

Re: attribute table

Did you try recalculating the image statistics using the Image Metadata tool (ImageInfo)? Open the Image Metadata tool by going to

ERDAS IMAGINE > Home tab > Information group > Metadata menu > View/Edit Image Metadata. In the Image Metadata tool click on Edit menu and select Compute Pyramid Layers/Statistics. In the Pyramid Layer/Statistics Generation Options dialog turn on the Compute Statistics option, set the X and Y skip factors to 1 and click OK. Reopen your TIFF image and open the raster attribute table.

 

Kind regards,

 

Stephen Bent

Hexagon Geospatial Support

Occasional Contributor
Posts: 6
Registered: ‎10-01-2018

Re: attribute table

Thanks a lot for the reply. It seems to be working!

 

Kind Regards,

Theju

Do you need immediate support?
If you encounter a critical issue and need immediate assistance please submit a Service Request through our Support Portal.