Hexagon Geospatial
MENU

ERDAS IMAGINE

Discuss and share topics of interest using ERDAS IMAGINE the world’s leading geospatial data authoring system.
Showing results for 
Search instead for 
Do you mean 
Reply
Occasional Contributor
Posts: 8
Registered: ‎03-28-2019

eATE problems for Ortho creation in Imagine Photogrammetry

I'm having problems getting the workflow for ortho creation to finish properly - not sure what the issue is.

 

  1. Using the Digital Camera sample dataset
  2. Following the steps in a combination of 2 seperate youtube vids - getting decent RMSE values

https://www.youtube.com/watch?v=Fns99nOt_mM

https://www.youtube.com/watch?v=wE6rkdyULpM

 

3. I dont seem to have license for any terrain extraction other than eATE - this will fail if i try classified las so usually stick to DEM only

4. The DEM column in the image table does not switch from red to gree here like it does when i look at the tutorial vids

5. When I try and do the ortho resampling step do I add the three images as input and specify three outputs (video 2) or just one (video 1)?

6. I've managed to get one file labelled as an ortho out of it, but its smaller than the middle image - so defeats the purpose kind of.

 

thanks in advance

Learn how to set up and manage a photogrammetry project in IMAGINE Photogrammetry using aerial images. Music: https://www.bensound.com
Staff
Posts: 130
Registered: ‎06-30-2016

Re: eATE problems for Ortho creation in Imagine Photogrammetry

Hi Conor,

 

  • DEM column turns green only when you extract DTM using ATE (which you said you don't have license for). But this will not affect ortho generation.

 

  • When you add multiple images for ortho resampling, you need just to enter one output prefix name and that will be prefixed to the names of the input images giving you as many output images as the input image.

 

  • Not sure I get the last question correctly, but ortho images may not be the same size as the input images. The extent of the ortho is determined by the intersection of the DEM and the input image. If the DEM does not cover the full extent of the image, you will only get an ortho for the part that is covered by the DEM.

 

Regards, Sam

 

Occasional Contributor
Posts: 8
Registered: ‎03-28-2019

Re: eATE problems for Ortho creation in Imagine Photogrammetry

Thanks Sam - very helpful.

 

I've tried both but will try again. When i specify the outut prefix and run the resmapling (with the three input images and the DEM) the progress bar shows that the first works but the second and third fail, so not sure whats up. Is it that the DEM doesn't overlap enough with those areas?

 

Is there any step by step guide ortho creation guide available that you are aware of?

Occasional Contributor
Posts: 8
Registered: ‎03-28-2019

Re: eATE problems for Ortho creation in Imagine Photogrammetry

I tried again - step by step. The ortho creation keeps failing - only on one image this time but the outputs have major errors - see swipe/screenshots in case anything occurs to anyone. The RMSE was 0.2161 In sequence the images are the processing element for the eATE, the ortho resampling menu with the DEM specified, the error in the process list and the orthos with errors. 

eATE Creation

 

 

Resampling.png

 

 

 

Error.JPG

 

 

 

Ortho_Errors.JPG

Highlighted
Staff
Posts: 130
Registered: ‎06-30-2016

Re: eATE problems for Ortho creation in Imagine Photogrammetry

I belive this is caused by an incorrect DEM. Try to ortho rectify it using an average elevation. (the constant option in DTM source). 

 

Regards, Sam

Occasional Contributor
Posts: 8
Registered: ‎03-28-2019

Re: eATE problems for Ortho creation in Imagine Photogrammetry

[ Edited ]

Thanks Sam, appreciate the help.

 

I tried the DEM with a constant elevation of 0 and it successsfully outputs the three orthos, although the overlaps between the three output orthos is very poor (inaccuracies of almost 1/4 of theimage) and i didnt even move onto the mosaicing. The image height for three images in the .dat file is 1851 approx - but the readme file for the Erdas sample data says 605m is the average flying height - so i took 1200 as the next constant DEM elevation value - this overlap was even worse.

 

I tried it again and just to test tried 605m - the average flying height AGL according to the readme - it worked and the overlap was much better, but I have no idea why this is.

 

1. Can you replicate this DEm creation error using the eATE tool and sample data? It is the sample ERDAS Digital Camera dataset.

2. Can you suggest a better DEM constant value?

3. I presume the error isnt in the readme file - and the average flying height should be 1800 approx?

 

It would be really useful if there was a tutorial video on ortho creation using one of these smaller sample datasets.

 

Thanks again for the help.

Occasional Contributor
Posts: 8
Registered: ‎03-28-2019

Re: eATE problems for Ortho creation in Imagine Photogrammetry

I managed to find an old LPS manual that shows the processes - and on page 154 - lo and behold it says to use 605 as constant DEM value (they did not use a DEM either).

 

http://geography.middlebury.edu/data/gg1002/Handouts/LPS_PM.pdf

 

I just dont get this - with flight height and constant DEM height as the same - your a terrestrial MMS photographing under the van, not an aerial platform? What would you do if ever trying this again for other projects? Always set it the same as the flight height?

Do you need immediate support?
If you encounter a critical issue and need immediate assistance please submit a Service Request through our Support Portal.