Hexagon Geospatial
MENU

ERDAS IMAGINE

Discuss and share topics of interest using ERDAS IMAGINE the world’s leading geospatial data authoring system.
Showing results for 
Search instead for 
Do you mean 
Reply
Highlighted
New Contributor
Posts: 2
Registered: ‎10-22-2017

"Viewer image does not match associated imate for signature set."

I am defining signatures using AOIs for a school assignment. I came back to continue to work on it, so I loaded by signature file in the Signature editor and began digitizing AOIs using the same image as before. I cannot add new signatures, any time I try I receive the following error: "Viewr image does not match associated image for signature set. Image associated may be edited with Edit menu (Image Association...) However when I go to the "Set Associated Image" dialog as instructed, I set the image to the same one I was working on (the only one I have ever used), and I still get the same error when trying to add a new signature. I have modified the bands being displayed in between but this should not affect the signatures, at least i would think so. Why am I receiving this error and how do I resolve it?
Staff
Posts: 582
Registered: ‎02-02-2016

Re: "Viewer image does not match associated imate for signature set."

What version of ERDAS IMAGINE are you using? Did you change your image in any way? For example, did you add or remove layers from the image? If the number of bands has changed in your image then you will be unable to associate it with the original signature file.

 

After you associate your image with the signature file again, save the signature file and close the Signature Editor dialog. Start a new session of ERDAS IMAGINE and try to create a new signature again.

 

Regards,

 

Stephen Bent

Hexagon Geospatial Support

Occasional Visitor
Posts: 1
Registered: ‎06-05-2018

Re: "Viewer image does not match associated imate for signature set."

Hi Hexagon Staff

I am posting on here on behalf of my remote sensing teacher and class of 16 students. We currently have ERDAS Imagine 2015 and 2018 32 and 64 bit versions. More specifically:

2018 Version 16.5.0 and build 852

We are having the same issue of undertaking a supervised signature classification by collecting signatures, then closing the session and re-opening it, and having issues with the signature file not associating with the exact same image used during signature collection. We have found, at times, collecting another signature does work to re-associate the file with the image, however this does not work every time. We have tried, prior to this, the conventional and advised strategy to re-associate the file with the image using the Image Association tool and saving and closing then re-opening. Still, this does not solve the issue of signature file not associating to the correct image.

We are wondering if there is an update for our version due to a possible software glitch or error we must know about?

Any advice would be much appreciated.

Thanks.

Do you need immediate support?
If you encounter a critical issue and need immediate assistance please submit a Service Request through our Support Portal.