GMSC Discussions

GeoMedia Smart Client community discussion board is where you can create, contribute and share information and knowledge in regards to configuring as well as working with GeoMedia Smart Client. Find your answers, share your knowledge and help build a strong GeoMedia Smart Client community.
Showing results for 
Search instead for 
Do you mean 
Regular Contributor
Posts: 246
Registered: ‎10-26-2015
Accepted Solution

Display CAD data in GMSC

I have an installation of GMSC 2016 SP3 that also has GeoMedia WebMap Essentials 2016 EP04 installed and I've attempted to display a Microstation DGN file as a feature.


I've created a CAD Schema Definition file (csd) and stored it under the ..\AppData\System folder of the GMSC Warehouse.

The CSD is configured to display data from all levels in a feature class called "AllLevels". This will return Compound Geometry and Text Geometry. The CAD file is stored locally on the same server.


The feature configuration in GMSC Administrator is as follows:



Geometry field: CompoundGeometry

Key field: ID

Feature Loader: Live

Interpretation: Default

Type: GeometryCollection

Is locateable: Disabled

Output Type: GdoPlus


Data Souce

Coordinate System: I've tried setting the coordinate system for the CRS of the data and CRS of the project.

Entity: AllLevels

Data source: CadServer

Connect: E:\Program Files\Intergraph\WebApplications\GMSC\Warehouse\AppData\System\CSD.csd


The test settings on the Edit Feature page in GMSC returns no errors.


The CAD data does not display in GMSC client. There are no errors in GMSC client log or server-side MapService.log. I can see log files are generated for GeoMedia WebMap logs but no log shows any attempt at connecting to the CAD data.


Can anyone suggest how I go about finding why the CAD data isn't displaying?




Regular Contributor
Posts: 246
Registered: ‎10-26-2015

Re: Display CAD data in GMSC

Just tried a new DGN file created using GeoMedia Desktop and that displays fine so its an issue with the first CAD file I was trying to display.