GMSC Discussions

GeoMedia Smart Client community discussion board is where you can create, contribute and share information and knowledge in regards to configuring as well as working with GeoMedia Smart Client. Find your answers, share your knowledge and help build a strong GeoMedia Smart Client community.
Showing results for 
Search instead for 
Do you mean 
Reply
Highlighted
Contributor
Posts: 20
Registered: ‎10-09-2017

GMSC Client - Infomode not working

Hi,

 

I'm facing an issue with my GMSC Client-Side Infomode. I've followed these steps in using the infomode:

 

1) Set Active a feature

2) Click Infomode located in the Settings tab in Search Panel

3) Select a feature

 

However, nothing appears after the selection. May I know what's the error?

 

infomode.png

Highlighted
Staff
Posts: 45
Registered: ‎02-27-2018

Re: GMSC Client - Infomode not working

I think you need to define a Query for the feature.

 

In the documentation (GMSC User Guide), it is stated that: Checking the Infomode (in the Settings) check box causes the query to be executed right after the feature selection.

 

In the GMSC Administrator, go to your feature and to the tab Queries.

 

There, create a query based on "Search with selection" as explained here: https://hexagongeospatial.fluidtopics.net/reader/89vp1839pXX8FFRYLqStog/9x7~XtmvPErJLj8TiwoHUw

 

In the select clause, put all the attributes that you want to see in your infomode.

Highlighted
Occasional Contributor
Posts: 13
Registered: ‎10-16-2016

Re: GMSC Client - Infomode not working

Hi,

 

Thank you for your response. I'm aware of the GMSC User Guide and has been using that as the guideline for my development.

However, the current issue that I've been facing are still occuring till now although the query and attributes have been defined in the Administrator side.

Highlighted
Staff
Posts: 45
Registered: ‎02-27-2018

Re: GMSC Client - Infomode not working

Hi comecoze79,

 

Is your Feature active in GMSC Client?

 

Have you define the query for "Search with Selection?

 

Do you see your query under the tab "Search with Selection" in the GMSC Client? Does it work when you select the qurey, select the objects in the map and then click on "Execute Search"?