GMSC Discussions

GeoMedia Smart Client community discussion board is where you can create, contribute and share information and knowledge in regards to configuring as well as working with GeoMedia Smart Client. Find your answers, share your knowledge and help build a strong GeoMedia Smart Client community.
Showing results for 
Search instead for 
Do you mean 
Reply
Highlighted
Contributor
Posts: 46
Registered: ‎06-18-2018

Raster Image in GeoMedia Smart Client

[ Edited ]

Hi,

 

We are trying to publish a Raster feature class in Smart Client.

The location of image is  '\\filestore\sgi_1$\DATA\IMAGERY\tst\Mosaic\' (attached screenshot).

When we are doing a Test settings getting an unexpected error. A double slash appears at the end of path in error log.


The error getting as below:

 

System.ApplicationException: `\\filestore\sgi_1$\DATA\IMAGERY\tst\Mosaic\\alaain-1mcol-260308.ecw' does not exist in the file system,
and is not recognised as a supported dataset name.

 

 

Attached is the screenshot from GeoMedia.

 

Thanks & Regards,
Anil

 

Highlighted
Technical Evangelist
Posts: 549
Registered: ‎09-11-2015

Re: Raster Image in GeoMedia Smart Client

Hi Anil,

 

I can see two possible sources of the problem. GMSC either does not like the dollar sign in the path, or it has problems reading the image. In order to verify the second, I would suggest you to copy the image somewhere to a local path does not containing the dollar sign, a test it from there.

 

Pavel

Highlighted
Contributor
Posts: 46
Registered: ‎06-18-2018

Re: Raster Image in GeoMedia Smart Client

Hi,

 

I copied the images in C drive. It is working fine from local drive. So there is no problem with image.

 

Now the question is why SmartClient appending double back slash to the image path.

 

In GeoMedia feature class path is '\\filestore\sgi_1$\DATA\IMAGERY\tst\Mosaic\alaain-1mcol-260308.ecw', whereas in the SmartClient error log the path shown is '\\filestore\sgi_1$\DATA\IMAGERY\tst\Mosaic\\alaain-1mcol-260308.ecw'. Why this double back slash? Is that valid?

 

Thanks & Regards,

Anil

Highlighted
Technical Evangelist
Posts: 549
Registered: ‎09-11-2015

Re: Raster Image in GeoMedia Smart Client

Hi Anil,

 

it is strange. I remember that I've managed to load images from a UNC path in the past. I would still recommed you to try to remove the dollar sign from the path, to see what happens.

 

Pavel