GeoMedia Discussions

Search for an answer, post a question, or answer other users' questions in our GeoMedia support discussions. This discussion board is a great way to collaborate with industry peers around the world. It is intended for discussion and support of the GeoMedia Desktop and Add-on applications.
Showing results for 
Search instead for 
Do you mean 
Reply
Highlighted
Frequent Contributor
Posts: 109
Registered: ‎09-18-2018

Issue : Geomedia text style on Labeling not working.

When I try to add an existing style. Geomedia won't recognize.

 

Capture.PNG

When I press ok when choosing the text style from my style library I will get the following label properties window:

Capture2.PNG

 

Not sure what am I missing here. Note that the style is not identified at all. Font, size and color doesn't match with my selection.

 

Cheers.

Highlighted
Super Contributor
Posts: 457
Registered: ‎10-12-2015

Re: Issue : Geomedia text style on Labeling not working.

I observe the behaviour when the style being chosen is a compound.

First example below will work - has single text, no compound folder:

test_SingularStyle.png

This example will fail as has the compound folder:

textStyleCompound.png

Highlighted
Frequent Contributor
Posts: 109
Registered: ‎09-18-2018

Re: Issue : Geomedia text style on Labeling not working.

Hi Shaun,

 

Thank you  for your answer on this.

In my case, neither the two approaches work for me. I can not create a label with Halo effect.

Highlighted
Super Contributor
Posts: 457
Registered: ‎10-12-2015

Re: Issue : Geomedia text style on Labeling not working.

Halo is not supported by the Label Manager Dialog.

https://hexagongeospatial.fluidtopics.net/reader/FqsYJDf8FOIave~S4FztXw/_i6ZBUiDFDm5mDwORBgpCQ

When selecting an existing named style to specify the label properties, only the Style characteristics noted on the Label Properties dialog box are recognized (Font, Bold, Italic, Size, and Color). All other style properties are ignored during label placement. This includes settings for Translucency, Rotation, Justification, Position, Frames, Halos, and any ABS settings defined on the Advanced tab of the Style Properties dialog box. Halos can be applied to labels after placement using the Change Label Properties (see Changing Label Properties) command.

You probably want to vote for one of the product ideas below:

https://community.hexagongeospatial.com/t5/Product-Ideas/Add-support-for-halos-around-labels-with-th...

https://community.hexagongeospatial.com/t5/Product-Ideas/Label-Manager-support-LabelWeb-definitions-...

(The first one has more votes so I would suggest it first)

 

By " neither the two approaches work for me.", do you mean you still see the problem you outline in your original post (Style shows size of 0 and wrong font) regardless of whether you have a single style without a folder? Or are you refering to halo not being supported?

Note: A style with a folder, even with a single text style will still fail. The style cannot have a folder.

Highlighted
Frequent Contributor
Posts: 134
Registered: ‎04-28-2016

Re: Issue : Geomedia text style on Labeling not working.

[ Edited ]

also in this idea ( dd. 10-04-2017 ............... now is 2020 ...........................)

https://community.hexagongeospatial.com/t5/Product-Ideas/Match-the-graphic-text-style-capabilities-o...

 

there are too many unresolved issues!

 

Giulio