GeoMedia Discussions

Search for an answer, post a question, or answer other users' questions in our GeoMedia support discussions. This discussion board is a great way to collaborate with industry peers around the world. It is intended for discussion and support of the GeoMedia Desktop and Add-on applications.
Showing results for 
Search instead for 
Do you mean 
Posts: 46
Registered: ‎06-22-2016

PostGIS tables created by GeoMedia can't be read by other GIS



I have a PostGIS database which I've set up last year using the old unofficial PostGIS Data Server. Any PostGIS enabled GIS application can access the spatial tables stored in this database without issues.


Now that GeoMedia officaly supports PostGIS, I've set up a new database and imported a spatial table from the old one.


However, tables created by GeoMedia 2016 cannot be properly loaded by other GIS software, like QGIS.


I noticed that GM2016 declares the geometry field as a generic GeometryZ. Before the new release, GeoMedia used to declare the geometry type in a explicit way using MultiPolygonZ, MultiPointZ or MultiLineStringZ instead of GeometryZ.


Geometry types declared by GeoMedia 2015


Geometry types declared by GeoMedia 2016



I took some screenshots to show you what's happening. I tried to load 2 spatial tables, one created using GeoMedia 2015 and the other by GeoMedia 2016. Both tables where created via Output to Feature Class from the same shapefile. When I loaded them into GeoMedia it worked fine, but when I tried to load them into QGIS only the table created by GeoMedia 2015 was succesfully displayed. The 2016 spatial table was listed as 3 different entries on QGIS and none of the multipart polygons stored in it where loaded and displayed in the map.


Spatial tables on GeoMedia


GeoMedia 2015 spatial table and QGIS


GeoMedia 2016 spatial table and QGIS



How can I share the tables created by GeoMedia 2016 with other GIS software?


Technical Evangelist
Posts: 172
Registered: ‎02-02-2016

Re: PostGIS tables created by GeoMedia can't be read by other GIS

The PostGIS data server uses two storage columns: one column is used to store the PostGIS’s native spatial data types (GEOMETRY); the second one is a binary column (bytea) storing the GDO (GeoMedia Data Object – GeoMedia’s native binary storage format) geometry blob used for unsupported geometries (for example, oriented points, text, and raster).


The native geometry column in PostGIS stores the exact representation for geometries that are currently supported by PostGIS. For unsupported GeoMedia geometry types, an approximation of the GeoMedia geometry type is stored in the native geometry column, while the actual geometry is stored in the bytea column. See also GeoMedia Help topic on PostGIS data storage requirements.


You have identified an issue where geometry containing arcs or geometry collections inserted into PostGIS by GeoMedia 2016 does not display in qgis.  Examples of GeoMedia created geometry that do not display in qgis:

  1. Point, Line, Area, Spatial Any (Compound) and Text geometries that contain 1 or more geometry collections.
  2. Lines, Areas or Spatial Any (Compound) geometries containing any arcs.

A development evaluation of this issue has been requested in CR 1-M0LGMF per SR 1-1328975591.