GeoMedia Discussions

Search for an answer, post a question, or answer other users' questions in our GeoMedia support discussions. This discussion board is a great way to collaborate with industry peers around the world. It is intended for discussion and support of the GeoMedia Desktop and Add-on applications.
Showing results for 
Search instead for 
Do you mean 
Reply
Highlighted
Frequent Contributor
Posts: 122
Registered: ‎04-02-2017

Unable to attach Excel text to Geomedia layout window

Hi there,

 

We are finding we cannot insert text from Excel into a Geomedia layout window, either by copy and paste or inserting object.

We just see the outline. The file is Excel 97-2003 version. We have 16.5.0 build 1109 installed.

This was also an issue before we upgraded to this version but it did work about six months ago.

Do you know what might cause this issue?

 

Thanks,

 

Josh

Highlighted
Frequent Contributor
Posts: 122
Registered: ‎04-02-2017

Re: Unable to attach Excel text to Geomedia layout window

Pasting from a data window isn't working either. It is definately on the clipboard as I can paiste into Word.

Highlighted
Staff
Posts: 156
Registered: ‎05-26-2016

Re: Unable to attach Excel text to Geomedia layout window

I was able to reproduce your problems with my new Windows 10 Laptop and created a support Ticket 00026994 for these issues.

 

This morning Hexagon Geospatial Support commented

 

"I've reproduced the blank frame when inserting an Excel spreadsheet into the Layout Windows on a Windows 10 machine

and filed a JIRA bug for the problem."

 

 

Highlighted
Frequent Contributor
Posts: 122
Registered: ‎04-02-2017

Re: Unable to attach Excel text to Geomedia layout window

Thanks Roland.

 

It's strange as it worked a few weeks back but that was probably before I upgraded to the new version.

 

Cheers,


Josh

Highlighted
Senior Member
Posts: 1
Registered: ‎06-04-2018

Re: Unable to attach Excel text to Geomedia layout window

Hi, we have just recently moved to Windows10 and are experiencing the same problem. Is there a solution available yet? We are on 16.00 build 1415. Many thanks

Highlighted
Staff
Posts: 156
Registered: ‎05-26-2016

Re: Unable to attach Excel text to Geomedia layout window

[ Edited ]

An update regarding this issue was provided a while back by Development. Per the research by Development the reported issue appears to be due to a Microsoft bug.

 

You can use the following workaround option:

This problem occurs due to a change in the order of preference for formats used to cache the presentation of OLE objects, along with an issue when using the Enhanced Metafile format. You can revert the change in behavior by explicitly specifying the order of format preference using the following registry key:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager

Under this key, add a new Multi-String value, named OlePictureFormatPreferenceList, with the value data:

METAFILEPICT
ENHMETAFILE
BITMAP
DIB
--------------------------------------------------------------

I have tested this workaround on my Windows 10 machine where the problem was occurring and can confirm that after adding the registry entry the issue of a blank frame when adding data from an Excel spreadsheet to the Layout Window was resolved for both the Insert Object and Copy/Paste workflows. Also worked for both of my customers who reported problem.

reg_capture.PNG