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GeoMedia application fails to start (no errors or exceptions) due to Citrix Receiver Hooking

by Technical Evangelist on ‎05-31-2018 03:48 PM (644 Views)

Symptoms

After attempting to start GeoMedia, no error messages are posted or displayed. The application simply does not start. The GeoMedia Configuration Wizard runs with no problems and when the configuration wizard runs, a license is checked out and immediately back into the concurrent license pool. When attempting to start GeoMedia.exe, no license is requested as if there is a disconnect of the application from the systems installed applications.
Additionally, no exceptions are logged to Control Panel > Administrative Tools > Event Viewer, in the Windows Logs > Application section.
In this case the system is Windows 7 and current Windows Updates have been installed and applied to the system.

Diagnosis

Running Process Monitor from Sysinternals, one can see GeoMedia.exe Process Name associated to Citrix related files:

  • RSHook.dll
  • MfApHook.dll

Citrix_Hooking.png

 

Solution

The user was able to resolve the issue after removing Citrx receiver (version 3.4). After removing the Citrix Receiver application, the GeoMedia Desktop application was able to start and open GeoWorkSpaces as expected.

 

This article may offer a little more information concerning hooking used by Citrix: https://helgeklein.com/blog/2015/10/citrix-xenappxendesktop-api-hooking-explained/ The article suggests other methods of disabling Citrix hooking via registry edits. This is also explained at: https://support.citrix.com/article/CTX107825 which offers instructions with RegEdit to exclude specific applications such as "GeoMedia.exe". This resolution has not been tested. A reboot may be required after any registry edits.

 

Key: HKEY_LOCAL_MACHINE\SOFTWARE\Citrix\CtxHook
Value Name: ExcludedImageNames
Type: REG_SZ
Value: GeoMedia.exe

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