Hexagon Geospatial
MENU

GeoMedia Smart Client

GeoMedia Smart Client community discussion board is where you can create, contribute and share information and knowledge in regards to configuring as well as working with GeoMedia Smart Client. Find your answers, share your knowledge and help build a strong GeoMedia Smart Client community.
Showing results for 
Search instead for 
Do you mean 
Reply
Occasional Contributor
Posts: 17
Registered: ‎10-09-2017
Accepted Solution

CustomCRS - Failed to generate package

[ Edited ]

 

Hi, I’ve tried generating a new custom coordinate package using https://gmscdemo.hexagongeospatial.com/CustomCs/ but unfortunately, it fails to generate the package. The following attachment shows the error that pop-up upon uploading the "usersref.xml" file.

 

 

package.jpg

 

I’ve followed the procedures to define my own “usersref.xml” file based from the documentation:

(http://smartclient.intergraph.at/documentation/images/7/71/ERDAS_APOLLO_Server_User_Guide.pdf - page...) and come up with the following:

 

<?xml version="1.0" encoding="utf-8" ?>

<SREF>

<PROJCS ID="3380" NAME="GDM2000 / Selangor Grid">

                                <UNIT ID="9001" />

                                <GEOCS ID="7019" />

                                <PROJECTION NAME="Cassini_Soldner">

                                                <PARAMETER NAME="central_meridian" VALUE="101.3891079138889"/>

                                                <PARAMETER NAME="false_easting" VALUE="-34836.161"/>

                                                <PARAMETER NAME="false_northing" VALUE="56464.049"/>

                                                <PARAMETER NAME="latitude_of_origin" VALUE="3.68464905"/>

                                </PROJECTION>

                </PROJCS>

</SREF>

 

 

Regards,

Jasmine

Technical Evangelist
Posts: 148
Registered: ‎10-20-2015

Re: CustomCRS - Failed to generate package

Hi Jasmine,

thanks for pointing that out. We found the issue and solved it.

 

Best Regards,

Steve

Occasional Contributor
Posts: 17
Registered: ‎10-09-2017

Re: CustomCRS - Failed to generate package

Hi Steve,

 

Glad to know that the issue has been resolved. However, I am still facing the same issue when I tried uploading the "usersref.xml" file. 

Is the problem occuring because of my "usersref.xml" file or other causes?

Technical Evangelist
Posts: 148
Registered: ‎10-20-2015

Re: CustomCRS - Failed to generate package

Hi Jasmine,

the custom crs platform still causes an issue? Or do you mean your new topic:

http://community.hexagongeospatial.com/t5/GeoMedia-Smart-Client/GMSC-2018-Custom-Coordinate-System-I...

 

Best Regards,

Steve

Occasional Contributor
Posts: 17
Registered: ‎10-09-2017

Re: CustomCRS - Failed to generate package

There was some issue occuring when I tried to generate another package yesterday using the custom CRS platform but I've found out that the error occurs due to the name that I used. Hence, the custom CRS platform issue has been resolved for me.

 

Thank you Steve.

Highlighted
Technical Evangelist
Posts: 148
Registered: ‎10-20-2015

Re: CustomCRS - Failed to generate package

About which name do you talk? Do you talk about a name which was used in your userref.xml?

Occasional Contributor
Posts: 17
Registered: ‎10-09-2017

Re: CustomCRS - Failed to generate package

The name that is available in https://gmscdemo.hexagongeospatial.com/. The package failed to generate when I used the following name. When I just renamed it to Cassini_Soldner, the package can be generated. Hence, I assumed that the error was due to the name used.

 

Name.jpg

Technical Evangelist
Posts: 148
Registered: ‎10-20-2015

Re: CustomCRS - Failed to generate package

Ah I see, you used the name GDM2000/Selangor Grid. Thank you for that hint, we will improve that.

Occasional Contributor
Posts: 17
Registered: ‎10-09-2017

Re: CustomCRS - Failed to generate package

Yes. It would be great if Hexagon could share any specifications for the NAME such as the use of special characters or others if there is any.

 

Thank you very much for your assistance Steve.

Technical Evangelist
Posts: 148
Registered: ‎10-20-2015

Re: CustomCRS - Failed to generate package

At the moment you must ensure that the name only uses valid filename characters.

Do you need immediate support?
If you encounter a critical issue and need immediate assistance please submit a Service Request through our Support Portal.