Hexagon Geospatial
MENU

GeoMedia Smart Client

GeoMedia Smart Client community discussion board is where you can create, contribute and share information and knowledge in regards to configuring as well as working with GeoMedia Smart Client. Find your answers, share your knowledge and help build a strong GeoMedia Smart Client community.
Showing results for 
Search instead for 
Do you mean 
Reply
Highlighted
Super Contributor
Posts: 301
Registered: ‎02-09-2016

GMSC freezes when loading the overview map

Hi all,

 

Our client is using GMSC 2015.0.3.0_20160616. Occasionally, when we launch the GMSC, (in 1 out of 5 times) the GMSC suddenly freezes as its overview map is loading, it seems to be choked and we end it up killing it from the Task Manager. We thought that our custom java plugins could be the cause, but after stripping all custom plugins, the issue still happens; however, we observe that it happens lesser (around 1 out of 7 times).

 

GMSC 2.png

 

I am have no ideas what causes it. Appreciate all ideas and suggestions on how investigate it.

 

Kind regards,

Staff
Posts: 1,036
Registered: ‎10-18-2015

Re: GMSC freezes when loading the overview map

Hi,

 

what is the content of the overview? Please provide for each layer information about datasource and loading mode.

 

thanks,

Stefano

Stefano Turcato
Presale Engineer
Hexagon Geospatial
Super Contributor
Posts: 301
Registered: ‎02-09-2016

Re: GMSC freezes when loading the overview map

Hi Stefano,

 

I investigated the overview layer. It only has 3 features that have a few number of instances, they are cached and from MS SQL. I experiment with them by taking one of them out in turn, but it does not solve the problem.

 

Then, I go back to the Java console and start looking at the features are loaded at the time the crash happens. There is one feature that appears in all the crashes, this feature is from MS SQL and cached, I also checked all its entries with STIsValid function and all of them pass. Additionally, I experiment it by changing the title settings, but the issue still occurrs. However, when I remove the right to see this feature from my role to stop the feature from loading, then it has not occurred after 20 tries. So, I consider it as a work around but still can't get to the bottom of the issue.

 

Kind regard

Do you need immediate support?
If you encounter a critical issue and need immediate assistance please submit a Service Request through our Support Portal.