IMAGINE Discussions

Discuss and share topics of interest using ERDAS IMAGINE the world’s leading geospatial data authoring system.
Showing results for 
Search instead for 
Do you mean 
Reply
Highlighted
Occasional Contributor
Posts: 6
Registered: ‎10-26-2015

Continuous to Thematic

I performed a unsupervised classification on a continuous image.  I have recoded down to a few classes.  When I open up the attribute table there are no colors that I can change or associated with the classes, only row and histogram.  When I view the metadata the TYPE is Continuous.  I went to edit and change layer type but the type does not change.  What am I missing here.  

 

Much Appreciated

Highlighted
Contributor
Posts: 26
Registered: ‎06-01-2016

Re: Continuous to Thematic

Hello William,

 

Did you edit the metadata in the Manage Tab > Edit Image Metadata? This seems to work for me, but running an edit through the metadata viewer does not.  

 

 

 

Regards,

Emily 

Highlighted
Frequent Contributor
Posts: 153
Registered: ‎10-27-2015

Re: Continuous to Thematic

This is classic Imagine failure. Having image file open in viewer prevents editing layer and changing layer type.

 

So when opening file to metadata editor make sure it is not open in Viewer in same time. Also different raster formats might act differently here. In Erdas own .img format this works easily than in some other formats (like TIF). I have not found the final logics of this issue but these two definetly affects on this issue.

 

 

timo

Highlighted
Technical Evangelist
Posts: 700
Registered: ‎02-02-2016

Re: Continuous to Thematic

Hi William,

 

When displaying your classified image in IMAGINE’s 2D Viewer be sure to choose Pseudo Color from the Display as menu under the Raster Options tab in the Select Layer To Add dialog.

 

display_as_pseudo_color.png

 

Regards,

 

Stephen Bent

Hexagon Geospatial Support

Highlighted
Occasional Contributor
Posts: 5
Registered: ‎06-20-2019

Re: Continuous to Thematic

I have a continuous map and want to convert it to thematic layer so i can do the accuracy assessment. I heard that it is possible to convert it using the model maker but I don't know which fonction i should use. Thanks in advance for the help

Highlighted
Technical Evangelist
Posts: 700
Registered: ‎02-02-2016

Re: Continuous to Thematic

Hello Salma,

 

You can convert your raster data from continuous to thematic using the Raster Output operator and setting the Thematicity value to Thematic. I have attached a simple spatial model you can use to perform this task.

 

continuous_to_thematic.PNG

 

Kind regards,

 

Stephen Bent

Highlighted
Technical Evangelist
Posts: 1,048
Registered: ‎10-01-2015

Re: Continuous to Thematic

You can also use the Set Thematicity operator if you need to change it within the body of a model (rather than on output)

 

them.PNG

 

Cheers

 

 

Ian Anderson
Chief Product Owner, Desktop Remote Sensing
Hexagon Geospatial
Highlighted
New Member
Posts: 1
Registered: ‎10-07-2020

Re: Continuous to Thematic

Hello Everyone,

 

I am experiencing issues with Erdas displaying my raster as continuous when the raster is thematic. I have attempted everyone's solution but it turns out that the data is thematic to begin with but when I pull up the metadata for the raster, it states that it is continuous. 

 

I have included two images that show the data being displayed as continuous in Erdas, and also being displayed as thematic in ArcGIS Pro. It may help to note that this is reclassified NLCD data. 

Highlighted
Technical Evangelist
Posts: 700
Registered: ‎02-02-2016

Re: Continuous to Thematic

Hi Landon,

 

Try changing the layer type using the Image Metadata tool. Click on the Edit menu and select Change Layer Type. You should see it change from Continuous to Thematic in the Layer Info section.

 

Kind regards,

 

Stephen Bent

Highlighted
Technical Evangelist
Posts: 1,048
Registered: ‎10-01-2015

Re: Continuous to Thematic

[ Edited ]

Hi @Landon 

 

@sbent  has offered two of the valid approaches above.

 

The other thing you can try is to first recalculate statistics using a skip factor of 1 (i.e. no skip factor). Then use Change Layer Type to mark the dataset as Thematic rather than Athematic. That way it will default to opening as PseudoColor in ERDAS IMAGINE's 2D View rather than as Greyscale.

 

Note that some third-party packages produce IMG files which are not quite to spec and this approach then does not work. If this is the case you'll need to go with one of the other two approaches above. 

 

Cheers

 

 

 

Ian Anderson
Chief Product Owner, Desktop Remote Sensing
Hexagon Geospatial