IMAGINE Discussions

Discuss and share topics of interest using ERDAS IMAGINE the world’s leading geospatial data authoring system.
Showing results for 
Search instead for 
Do you mean 
Reply
Highlighted
New Contributor
Posts: 3
Registered: ‎07-05-2016

ERDAS IMAGINE 2016 Map Composition: Missing or invalid symbol when trying to print as IMG

I built 2 maps as a Map Composition in ERDAS IMAGINE 2016, for both maps I built my own simbology.

So, I'm trying to print this maps as "IMG" files, but I get this warning window every time it start rasterizing the point vectors: "A symbol is being referenced that is invalid or has been deleted from symbol library 'default.sml'. Using default symbol"

The result is the map as img file but all point simbology turns into the cross black symbol, I have this problem only with points simbology, all the other symbology looks fine.

I hope anyone could help me to get rid of this problem.

Thanks

Highlighted
Technical Evangelist
Posts: 218
Registered: ‎02-12-2016

Re: ERDAS IMAGINE 2016 Map Composition: Missing or invalid symbol when trying to print as IMG

Hi,

 

Custom symbols are saved in the user’s IMAGINE homespace folder C:\Users\<username>\.imagine1600\Symbols. The symbol is saved in the file ‘default.sml’ located in that folder. The error is complaining that the custom symbol used in the map composition was not found in that symbol library file. Check to be sure the file is present. If the file is there, check to see if the symbol is there by locating it from the Drawing tab > Styles category > Symbol Chooser.

 

08/02/17 13:09:03 SessionMgr(4328): WARNING: A symbol is being referenced that is invalid or has been deleted from symbol library "default.sml". Using default symbol.

 

Regards,

Jeff