IMAGINE Discussions

Discuss and share topics of interest using ERDAS IMAGINE the world’s leading geospatial data authoring system.
Showing results for 
Search instead for 
Do you mean 
Posts: 36
Registered: ‎05-02-2018

Re: Imagine photogrammetry SGM error

[ Edited ]

I uninstall and reinstall Imagine 2018 (with the update) and now, when I open the SGM module, Imagine immediately crash.

Technical Evangelist
Posts: 717
Registered: ‎02-02-2016

Re: Imagine photogrammetry SGM error

Is the software closing as soon as you click on the Tridicon Semi-Global Matching (SGM) button? Are there any errors reported in the session log?




Stephen Bent

Hexagon Geospatial Support

Posts: 36
Registered: ‎05-02-2018

Re: Imagine photogrammetry SGM error

[ Edited ]

No error reported.
Actually, Imagine freeze and I can't do anything more. If I click somewhere, Imagine's window become blank and the Windows pop up "Erdas Imagine not responding".
I've got this problem after trying to add DEM on the Elevation Library and making some changes. Can the problem be link to the Elevation Library ?

It's quite strange, for sure ! I tried to reinstall everything but the Elevation Library was the same as before the uninstall, I didn't found how to restore the default DEM on it.

Tomorow I will try to use an other computer, here I'm using a Virtual Windows on a Linux machine.


I don't know if the logfile can help but here is the status obtained after opening photogrammetric project and running the SGM module :
07/08/18 19:07:43 eWkspace_64(3892): Starting IMAGINE Photogrammetry
07/08/18 19:11:36 SessionMgr(5892): external process exited with status -805306369.


It's always the same code (-805306369).


Edit1 :

After some tests, when only one image is setted as "Active" in the Images pannel, the SGM module window is opened correctly. But setting only one image as Active is a problem to get some pairs Smiley Frustrated


Edit2 :

I restored the default files of the Elevation Library (by removing the defaultElevationLibrary.esl on the .imagine1650 directory, as suggested on an other topic. And now, I can use the SGM Module Smiley Very Happy Keep in touch to see if I still have the same error that I had on the begining of this topic Smiley Happy

Posts: 36
Registered: ‎05-02-2018

Re: Imagine photogrammetry SGM error

[ Edited ]

Hello everyone,

To comeback to the initial problem of the topic, when I want to create a DSM from satellite images with Imagine 2018 and Tridicon Semi Global Matching (SGM) I've got the following error :


TridiconSGMUTIL: Message:: Method not found: 'Int32 System.Environment.get_CurrentManagedThreadId()'.
SessionMgr(5376): TridiconSGMUTIL.exe exited with status 2.
SessionMgr(5376):  exited normally.



When I take a look on the SGM directory with the output files generated, I have not the .pyr files on it.

Here is the files created on the SGM directory :


I use the following workflow :

  1. Open Erdas Imagine 2018
  2. On Contents pannel, I click on 2D View #1
  3. I select New Photogrammetric Project...
  4. I give a name to the Block File
  5. On the Geometric Model Category, I choose Rational Functions and then, I select the Pleiades RPC as Geometric Model.
  6. I've got 4 sub-menu :
    1. Images
    2. Orthos
    3. Terrains
    4. Points
  7. I do a right click on Images to select Add Images
  8. Then, I select the Pleiades images wanted by selecting the DIMAP files.
  9. I do it for the 3 images of the Tri-Stereo
  10. I give the Interior Orientation, delivered with the DIMAP files, for each images.
  11. On next step, I calculate the Tie Points by clicking on the Point Measurement, then Automatic Point Measurement (APM)
  12. When the Tie Points are calculated, I click on Block Triangulation, then Block Triangulation, then Accept.
  13. Here is the part using the SGM module :
    1. I click on Generate, then Tridicon Semi-Global Matching (SGM)
    2. For each pairs, the Status is Not Ready, I click on it and ask to recalculate the files for each pairs.
    3. The calcul of epipolar is done and a progress bar appear, no error occur here (or at least, no error is reported).
    4. When all the calculs are done and so the Status of each pairs became Ready, I click on Run Now in the SGM window.
    5. The calcul is then, instantly finished with a Failed Status.

Is there something wrong on my workflow ? If so, please do not hesitate to inform me.


The deal of my work here is to perform this calculation on 12 Tri-Stereo to create an orthophoto mosaic. To do that, I need to calculate an DSM of all these 12 Tri-Stereo on one time with a block file. To start (it's the first time I'm using Imagine), I want to calculate a DSM for only 1 Tri-Stereo, just to try it and see if the workflow is correct.


Thank's everyone for your time,
Best regards,


PhD. Student

Posts: 36
Registered: ‎05-02-2018

Re: Imagine photogrammetry SGM error

I'm trying the same workflow on another computer and here when I run the SGM tool (step 13.4 from previous message), the .pyr are generated and .las is calculating !
So I think it's working on this computer (process still in calculation).

Do you have any idea why this is not working on my main computer ?

New Contributor
Posts: 5
Registered: ‎07-19-2018

Re: Imagine photogrammetry SGM error

Hello Dear, what's this .pyr file u mentioned?