IMAGINE Discussions

Discuss and share topics of interest using ERDAS IMAGINE the world’s leading geospatial data authoring system.
Showing results for 
Search instead for 
Do you mean 
Reply
Visitor
Posts: 1
Registered: ‎10-04-2020

PCA output

I have been succesfully running PCA, however the tool now outputs a blank image. This is happening even when re-running with images that have succesfully been computed.

 

The input images are stacked sentinel 2, sentinel 1 and selected indices.  

 

Can anyone help?

Technical Evangelist
Posts: 712
Registered: ‎02-02-2016

Re: PCA output

Hi robotninja,

 

1a. Has anything changed between when Principal Components was working and now?

1b. Did you happen to update your version of ERDAS IMAGINE?

1c. What version of ERDAS IMAGINE are you using?

 

2a. Are you using the Principal Components tool found under the Raster tab? (Raster tab > Resolution group > Spectral menu > Principal Components)

2b. Or are you using the Principal Components operator in a spatial model?

 

3a. Can you provide a detailed description of the input data?

3b. Are you stating that the input image is a stack of Sentinel-2, Sentinel-1 and various indices all combined in one image file?

 

4. Does the ERDAS IMAGINE session log show any warnings or errors during the principal component process? (File tab > Session > View Session Log).

 

5. If you open one of your blank principal components images in the Image Metadata tool (Home tab > Information group > Metadata) what does it report for the statistics info under the General tab?

 

Regards,

 

Stephen