Hexagon Geospatial
MENU

ImageStation

Discuss topics about Imagestation, which powers high volume photogrammetry and production mapping workflows.
Showing results for 
Search instead for 
Do you mean 
Reply
New Contributor
Posts: 3
Registered: ‎07-29-2019

Stealth Mouse movements (Z) are not smooth in ISAT Stereo Detail view

I am trying to use the Stealth 3d Mouse S3-V in ISAT 2018.

The Stealth mouse is recognized, and the buttons are working as shown in in the help documentation diagrams.

 

However the Z movement is not very smooth... its a coarse jump in Z elevations... at times making it difficult (or impossible) to accurately place the crosshair on the ground... it either appears a little high or a little low.

 

I use the "mensuration" speed setting, trying to get an accurate reading in 3d. (Though I've tried "high" and "low" also.)

When I turn the wheel slowly, trying to fine-tune my reading, it can take quite a bit of turning to see any change in the Z of the cursor... but when it does change it is a jump.

 

In other software (such as DATEM Summit Evolution) I don't see this behavior... it is very smooth.  I don't see any other settings within ISAT to help me control this.  Does anyone have tips or suggestions on getting smoother Z movements in ISAT when in Stereo Detail view?

Staff
Posts: 147
Registered: ‎02-11-2016

Re: Stealth Mouse movements (Z) are not smooth in ISAT Stereo Detail view

My first question is what zoom factor are you measuring at in the Detail view? Also, can you use the Ctrl button and lock one photo and move the other photo in roam to clear as a workaround?

New Contributor
Posts: 3
Registered: ‎07-29-2019

Re: Stealth Mouse movements (Z) are not smooth in ISAT Stereo Detail view

  • Zoomed @ 2:1
  • Yes the control key works to hold image still... as does button on puck to simulate ctl key... maybe marginally better, but even there the adjustment isn't as fine and smooth as I want it to be... its still feels like it jumps in elevation, rather than smoothly transitioning through entire range.  

 

The point of trying to use the stealth 3d mouse was hoping for a "Fine-tune" when reading Z... as it seems very coarse with standard mouse.

This coarseness continues when using the Z wheel of the Stealth 3d.

 

(The puck also effectively lets me forego toggling y-parallax lock, since the Z wheel basically does that for me, while another button locks the left image when I need to clear parallax.)

 

I don't see this same coarse behavior with the Stealth 3d-Mouse in other mapping software I use, so either I'm missing a setting somewhere, or ISAT just isn't as good at reading the Z adjustments as I'd hoped,  which is frustrating.  I wonder how the Z behaves in the other Imagestation tools... but I only use ISAT, myself.

 

Thanks for the reply.

Staff
Posts: 147
Registered: ‎02-11-2016

Re: Stealth Mouse movements (Z) are not smooth in ISAT Stereo Detail view

Please confirm you have the speed mode set to Mensuration mode? Left Shift + first base changes the setting.

New Contributor
Posts: 3
Registered: ‎07-29-2019

Re: Stealth Mouse movements (Z) are not smooth in ISAT Stereo Detail view

Thank you.

Yes, I am using the mensuration mode. I watch the messages @ bottom of screen to confirm I'm in that mode.

It does slow the movement down, of course.  It also seems that when I turn the z-wheel very slow it feels like I can turn it for a long-time before any apparent z change happens in my stereo-view... (and when the z change happens it is still a coarse movement.)

 

(Side note... interesting you refer to button as 1st base, like a basball diamond; that's the same description we use for the buttons around here too. I had thought maybe it was a local thing.)

Staff
Posts: 63
Registered: ‎02-04-2016

Re: Stealth Mouse movements (Z) are not smooth in ISAT Stereo Detail view

[ Edited ]

Hello,

I have a suggestion that you can try...

 

This requires that you have ImageStation 2018 Update 2 installed on your system, specifically, you should have ISAT version 16.5.0.566. Mind you that although this release is referred to as "Update" 2, it requires that you remove any previous version of ImageStation applications before installing this one. Also, if you have GeoMedia and any GeoMedia Add-ons, they must be updated to "Update 2" before proceeding as well.

 

With that done, you can disable the non-linear behavior of the Z motion by cutting and pasting the following 3 lines into a text file and giving the text file a ".reg" extension. Once that's done, double-click on the file and confirm the prompt to add these settings to your registry. This targets the HKEY_Current_User registry so no special permissions are needed.

 

Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\ZI Imaging\MouseBallistics]
"Z3DMUseMouseBallistics"="0"

 

Once this is finished, restart ISAT and proceed as normal. Personally, I prefer to have the cursor speed set to "Low" for this environment. If set to Mensurate I find that it is still possible to move slow enough such that the Z doesn't change. In any case, you can experiment and see if it helps.

 

If you want to re-enable the default motion you can edit the registry at this location and set "Z3DMUseMouseBallistics"="1" (or simply delete the key altogether). I should also point out that this functionality was implemented with the "Z Type" Stealth Mouse so I am not certain it will have the same effect on your "V Type," but I believe it will.

 

HTH,

Eric

Do you need immediate support?
If you encounter a critical issue and need immediate assistance please submit a Service Request through our Support Portal.