Hexagon Geospatial
MENU

Licensing Knowledge Base

Easily license Hexagon Geospatial desktop products using the License Manager .
Showing results for 
Search instead for 
Do you mean 

ERDAS IMAGINE 2018 can be slow to start.

by sbent ‎08-14-2018 10:49 AM - edited ‎08-19-2019 09:58 AM (1,079 Views)

Question

When launching ERDAS IMAGINE 2018 it can take a minute or longer for the software to start. The same slowness can also occur when opening individual ERDAS IMAGINE tools and modules.

Answer

This issue has been fixed in an updated version of the Geospatial License Administrator (v16.5.0.21).

 

If you cannot update your version of the Geospatial License Administrator please set a system environment variable when using a proxy server. Create the system environment variable https_proxy on the client and server machines using this format:

https_proxy=http://username: password@proxy.company.com: port 

 

If you do not need a username and password, you can use the following format: 

https_proxy=http://proxy.company.com: port

Replace the following fields with the actual information for your system: username, password, proxy.company.com, port.

 

Examples:

username:  erdas1user
password:  imagine2pass
proxy.company.com:  proxy.hexagon.com or 129.136.158.119
port:  321


https_proxy=http://erdas1user:imagine2pass@129.136.158.119:321

https_proxy=http://erdas1user:imagine2pass@proxy.hexagon.com:321 
https_proxy=http://proxy.hexagon.com
https_proxy=http://proxy.hexagon.com:321
https_proxy=http://129.136.158.119
https_proxy=http://129.136.158.119:321

Comments
by andrew.watson
on ‎09-04-2018 01:03 PM

I have this problem but we do not have a proxy server.

by jdooley
on ‎09-05-2018 10:31 AM

Hi Andrew,

 

Please submit a Support ticket to discuss the details of your problem. Information found to be relavant to other users can be posted once your problem is sorted out.

 

Kind regards,

 

Jeff Dooley

Post-Sales Engineer - Remote Sensing

Hexagon Geospatial

by jdooley
‎09-10-2018 03:52 PM - edited ‎09-11-2018 05:23 AM

A solution was found from the support ticket submitted for Andrew’s problem of observing a slow IMAGINE startup. The longer than expected IMAGINE startup time was caused by a network connection delay of the client machine to the license server machine. The client establishes a TCP/IP port connection with the license service, lmgrd, that runs on the server machine.

 

A default port range of 27000-27009 is used by the license service. If the license client does not know the exact TCP/IP number used by the license service, the client must search to find the correct connection port in that range. This search time is usually minimal and does not impose a significant wait time for the connection. The connection time varies from network to network and sometimes the delay becomes noticeable, especially on busy networks.

 

The client connection time can be optimized by pointing the client machine to the explicit TCP port number used by the license service.

 

Try this simple modification:

  1. Go to the server machine folder C:\Users\Public\Intergraph\Licenses. Using a text editor, open the file ‘IntergraphLicensingService.log‘. Find the license service (lmgrd) TCP port address. Look for a line that resembles the example below where the lmgrd port is set to 27001.

 

17:55:26 (lmgrd) lmgrd tcp-port 27001

 

  1. On the client machine, open the Geospatial License Admin Tool. Select the menu option View > Add Concurrent License Source. Enter the server name in the Computer name window and the lmgrd port number (e.g. 27001) in the Port window. Restart IMAGINE from the client.

 

add_concurrent.PNG 

 

Regards,

Jeff

Contributors