M.App Enterprise Discussions

Discuss topics with other M.App Enterprise Product pioneers and experts to get the most out of it.
Showing results for 
Search instead for 
Do you mean 
Reply
Highlighted
Staff
Posts: 32
Registered: ‎01-25-2019

Invalid Authentication to Fusion

Hi - when opening LuciadFusion Studio from M.App Enterprise studio, I use the url http://myserver:443/studio/index.html#/?refresh_token=2f301ca3-7051-462e-af10-bde87661ecf8&tenant=De...

but then get the message - 

 

Invalid M.App Enterprise Authentication Information

The M.App Enterprise authentication information provided to Fusion Studio is invalid or expired, launch Fusion Studio from M.App Enterprise Studio again.

 

How to resolve this please?

Thanks

Highlighted
Technical Evangelist
Posts: 712
Registered: ‎11-12-2015

Re: Invalid Authentication to Fusion

Hi Richard,

 

Use the developer console (F12 most browsers) of the browser to glean some clues here.

In particular pay attention to the POST for the 'token' and the response

 

Request URL:

http://server/api/v1/oauth2//token
Request Method:
POST
 
If there is an issue with authentication there should be some information to gather from the developer console or even in the M.App Studio log.
 
HTH
Highlighted
Technical Evangelist
Posts: 164
Registered: ‎09-01-2015

Re: Invalid Authentication to Fusion

Hi Richard,

 

is it a typo on your side or why are you using http:// with port 443?

 

If you have a look here:

https://community.hexagongeospatial.com/t5/M-App-Enterprise-Tutorials/Installing-Luciad-Fusion-for-M...

you should find the answer to your problem. 

 

 

Kind regards,

Stefan

Highlighted
Staff
Posts: 32
Registered: ‎01-25-2019

Re: Invalid Authentication to Fusion

Stefan - I found that including :443 got me past a 'This site can’t be reached' timeout. I now cannot get a response from Fusion server.   I do not understand how application-fusion.production.yml should be edited - do you have an example?

 

And as of yet, nothing in F12 console.

 

Thanks

 

 

Highlighted
Staff
Posts: 32
Registered: ‎01-25-2019

Re: Invalid Authentication to Fusion

I am working via HTTP and have now a CORS error. Where can I alter to correct this? Thanks

 

Untitled.png

Highlighted
Staff
Posts: 1,065
Registered: ‎10-18-2015

Re: Invalid Authentication to Fusion

Hi Richard,

 

if you work over http please configure fusion with a different port, like 8080.

If you want to use https you will have to provide a valid SSL certificate...

 

Stefano

Stefano Turcato
Presale Engineer
Hexagon Geospatial
Highlighted
Staff
Posts: 32
Registered: ‎01-25-2019

Re: Invalid Authentication to Fusion

Stefano - I have modified the Fusion installation to use 8080, with no change. I am happy using HTTP everywhere as this is for demo only. Next step is to try and trace calls from client browser, to Fusion server. Thanks, Richard