M.App Enterprise Discussions

Discuss topics with other M.App Enterprise Product pioneers and experts to get the most out of it.
Showing results for 
Search instead for 
Do you mean 
Reply
Occasional Contributor
Posts: 16
Registered: ‎10-29-2015
Accepted Solution

Invalid date in BI wizard

Hi I have a data service that produces a datum colum which looks as follows:

2018-08-19T19:58:42.628Z

 

When I try to match the input as variables as:

%Y-%m-%dT%H:%M:%S.%LZ

I get an invalid date message in my Custom Attribute colum (for extracting Year for example)

And I get 'Wrong date format or attribute' when trying to create a time dimension based on this field.

I suspect that the two letters T and Z are the cause is there any way without changing the input data to get this to work?

 

Kind Regards,

 

Dennis

Staff
Posts: 1,054
Registered: ‎10-18-2015

Re: Invalid date in BI wizard

[ Edited ]

Hi Dennis,

 

this post should be relevant to your use case:

http://community.hexagongeospatial.com/t5/Smart-M-App-Tech-Discussions/How-to-properly-configure-Tim...

 

HTH, Stefano

Stefano Turcato
Presale Engineer
Hexagon Geospatial
Occasional Contributor
Posts: 16
Registered: ‎10-29-2015

Re: Invalid date in BI wizard

Hi Stefano,

 

I had seen that information, but it is not working for me. All values are filled (each row has a valid date in the same format), so far I can see my pattern is the same as the content, but still it does not work.

 

I have tried many differend options but none of them work.

In your 2nd link there is a exsample of a variable for strictIsoParse, this is exactly the format of my datetime colum, but it does not work in the BI wizard either as custom attribute or time dimension.

var strictIsoParse = d3.utcParse("%Y-%m-%dT%H:%M:%S.%LZ");

Kind Regards,

 

Dennis

 

Occasional Contributor
Posts: 16
Registered: ‎10-29-2015

Re: Invalid date in BI wizard

Hi Is there any aditional information available today I got confronted with the same problems again.

When I have a colum combining the datum and time it does not work, when I have a colum with only the datum it does work. But that is not enough for the intended M.app.

 

Kind regards,

 

Dennis

Technical Evangelist
Posts: 658
Registered: ‎11-12-2015

Re: Invalid date in BI wizard

[ Edited ]

Greetings all,

 

Dennis found the issue to be the date values had a leading space character that was not being accounted for with the date/time variables.

For date/time format issues please refer to the document Stefano has linked above and if no resolution is forth coming from that contact support.