Hexagon Geospatial
MENU

M.App Enterprise

Discuss topics with other M.App Enterprise Product pioneers and experts to get the most out of it.
Showing results for 
Search instead for 
Do you mean 
Reply
Highlighted
Staff
Posts: 106
Registered: ‎11-24-2015

Creating My Geoservice is not working on a specific installation

Have been able to import data from and Oracle db

Can see the features in the Content area.

Want to use these features in Browser app as a WMS background

 

Try to setup WMS in My Geoservices and when I hit Save, it thinks for a short while then just returns to the setup My Geoservice screen. Have been able to do this on another install.

 

This is the error logged:

 

System.AggregateException: One or more errors occurred.     [Aggregated exceptions]  System.Net.Http.HttpRequestException: An error occurred while sending the request.       --- Inner exception ---  System.Net.WebException: Unable to connect to the remote server     at System.Net.HttpWebRequest.EndGetResponse(IAsyncResult asyncResult)     at System.Net.Http.HttpClientHandler.GetResponseCallback(IAsyncResult ar)     --- Inner exception ---  System.Net.Sockets.SocketException: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond 85.222.129.185:443     at System.Net.Sockets.Socket.EndConnect(IAsyncResult asyncResult)     at System.Net.ServicePoint.ConnectSocketInternal(Boolean connectFailure, Socket s4, Socket s6, Socket& socket, IPAddress& address, ConnectSocketState state, IAsyncResult asyncResult, Exception& exception)  System.AggregateException: One or more errors occurred.     [Aggregated exceptions]  System.Net.Http.HttpRequestException: An error occurred while sending the request.       --- Inner exception ---  System.Net.WebException: Unable to connect to the remote server     at System.Net.HttpWebRequest.EndGetResponse(IAsyncResult asyncResult)     at System.Net.Http.HttpClientHandler.GetResponseCallback(IAsyncResult ar)     --- Inner exception ---  System.Net.Sockets.SocketException: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond 85.222.129.185:443     at System.Net.Sockets.Socket.EndConnect(IAsyncResult asyncResult)     at System.Net.ServicePoint.ConnectSocketInternal(Boolean connectFailure, Socket s4, Socket s6, Socket& socket, IPAddress& address, ConnectSocketState state, IAsyncResult asyncResult, Exception& exception) 

 

A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond 85.222.129.185:443

 

 

Any ideas?

Staff
Posts: 965
Registered: ‎10-19-2015

Re: Creating My Geoservice is not working on a specific installation

Hi,

 

it seems to be a network problem. Are you using IP address to access Studio? Could it be a rotuing issue because also of port 443 (SSL)?

 

Best regards,

Stefano

Stefano Turcato
Presale Engineer
Hexagon Geospatial
Staff
Posts: 106
Registered: ‎11-24-2015

Re: Creating My Geoservice is not working on a specific installation

Hi Stefano,

 

Thanks for the reply -  the Studio is being accessed using the alias https://dhomapp01/Studio....

 

Could this be the problem? 

 

The studio appears to perform as normal - it's only when we attempt to publish Geoservices (WMS) that it fails with this error.

 

Jonny.

Staff
Posts: 106
Registered: ‎11-24-2015

Re: Creating My Geoservice is not working on a specific installation

PS: It's also using the self-signed SSL certificate - could that be the issue? For geoservice publishing is a proper/domain certificate needed?

Staff
Posts: 965
Registered: ‎10-19-2015

Re: Creating My Geoservice is not working on a specific installation

no, it is not needed, should work anyway. Do you have any proxy on your browser/network? Is the machine name published in the DNS server? Can you try to put the machine name in your windows "hosts" file? What are the binding settings for M.App website in IIS?

Stefano Turcato
Presale Engineer
Hexagon Geospatial
Staff
Posts: 106
Registered: ‎11-24-2015

Re: Creating My Geoservice is not working on a specific installation

Hi Stefano,

 

I will be back onsite on Thursday and can check the questions above...

 

Here is what we can do... we can access the MApp Enterprise server from a client machine using the server name. The MApp Enterprise Studio can access/import the Oracle server features (Oracle Client 64-bit has been installed on the MApp Enterprise server).

I don't have access to the client machine now, but I assume it has access also to the Oracle server because it is the GIS Managers PC.

 

Previous communications have suggested that Oracle 11g is not officially supported but it should work. Maybe this is the problem?

 

Thanks,

Jonny

Do you need immediate support?
If you encounter a critical issue and need immediate assistance please submit a Development Ticket through our Development Ticket Portal.