Hexagon Geospatial
MENU

M.App Enterprise

Discuss topics with other M.App Enterprise Product pioneers and experts to get the most out of it.
Showing results for 
Search instead for 
Do you mean 
Reply
Occasional Contributor
Posts: 14
Registered: ‎02-13-2018
Accepted Solution

Internal server error while adding content

[ Edited ]
Hi Community,
 
during weekend we configured our M.App Server, and now it is accessible over https. We bought certificat and domen.

Unfortunatelly when I want to add new content, occured  Internal Server Error.
 
 
internal server error.JPG
 
Where should I looking for a problem?
 
Best,
Rafał
Regular Contributor
Posts: 203
Registered: ‎03-10-2016

Re: Internal server error while adding content

Hi Rafal,

 

have you checked the documention?

 

Imagery

 

Adding new imagery

 

Name -- Defines a name of the imagery.

Path -- Defines where the imagery is located. You have to copy paste the location into this field.

Please note that the path must be UNC specific.

If you define a folder, the containing images are virtually merged together to one image (Mosaic option in Apollo Essentials).

If you define a folder, please note that the images have to be spatially correlated.

 

 

I think you only need the folder, not the image (.img) and your path must be UNC \\localhost\123\

 

Regards

Stefan

GAUSS Ingenieurtechnik GmbH | Germany
Occasional Contributor
Posts: 14
Registered: ‎02-13-2018

Re: Internal server error while adding content

Hi Stefan,
yes, I have checked documentation allready.
I use unc path, but I still cannot add new content.

Before installation of certificate my data were accessible using
\\server IP\Warehouse\name.img or D:\Warehouse\name.img where both path are valid.
My img is located on M.App Serwer on local disc in folder Warehouse (selected as Warehouse during M.App Instalation).

I assumpt that my error is associated with installation of certificate.

Could you tell me how should I modify my configuration?

Best,
Rafał

Regular Contributor
Posts: 203
Registered: ‎03-10-2016

Re: Internal server error while adding content

What about the logs?

Have you checked SECURITY -->LOGS in Studio?

GAUSS Ingenieurtechnik GmbH | Germany
Occasional Contributor
Posts: 14
Registered: ‎02-13-2018

Re: Internal server error while adding content

Unfortunately there aren't logs from this event.

 

I have got only error in developer console:

developer console.JPG

 

Rafał

Staff
Posts: 942
Registered: ‎10-18-2015

Re: Internal server error while adding content

is this D drive a local drive or a mapped drive? I don't think the issue may be related to  SSL...

Stefano Turcato
Presale Engineer
Hexagon Geospatial
Occasional Contributor
Posts: 14
Registered: ‎02-13-2018

Re: Internal server error while adding content

Hi Stefano,

 

D is a local drive.

 

Rafał

Staff
Posts: 942
Registered: ‎10-18-2015

Re: Internal server error while adding content

I cannot reproduce your issue. On the server under the warehouse folder there is a file named IWS.db: can you try to move it to another location and try to register the image again in Studio?

Stefano Turcato
Presale Engineer
Hexagon Geospatial
Occasional Contributor
Posts: 14
Registered: ‎02-13-2018

Re: Internal server error while adding content

Changing the location of the IWS.db file does not change anything. I still get an internal server error.

 

Rafał

Occasional Contributor
Posts: 14
Registered: ‎02-13-2018

Re: Internal server error while adding content

I made the installation again with the creation of a new master db, I also tried configuration in which Warehouse moved to the system disk. But the same problem still exists.

 

Rafał

Polls
Please register to vote
Do you need immediate support?
If you encounter a critical issue and need immediate assistance please submit a Development Ticket through our Development Ticket Portal.