Hexagon Geospatial
MENU

M.App Enterprise

Discuss topics with other M.App Enterprise Product pioneers and experts to get the most out of it.
Showing results for 
Search instead for 
Do you mean 
Reply
Frequent Contributor
Posts: 114
Registered: ‎05-25-2016
Accepted Solution

Trigger not working in mobile app

[ Edited ]

Following this topic, I´ve encountered a problem with the SQL trigger. As I´ve mentioned there, I’ve set a trigger in my shell that should be executed on after save and after update. The trigger is firing as it should but the query it´s sending is not working. The trigger´s definition looks like this:

 

<Entity.Triggers>
	<SqlTrigger Id="UpdateTrigger" Method="AfterSave,AfterUpdate" Sql="UPDATE reportes_3857 SET nomloc = 'trigger test text' where id=@{id} "/>
</Entity.Triggers>

 

 

As far as I understand,  @{id} should be substituted by the application with the corresponding value, but that’s not the case, according to the postgres logs the app is sending the query as it is ( id=@{id} ) .

 

What i´m assuming is that, since the workflow is creating a new record, there is no value assigned @{id} and the trigger gets no value to use. If I omit the trigger, the app creates a guid for the record when it gets saved.

 

Am I missing something?

Staff
Posts: 1,011
Registered: ‎10-19-2015

Re: Trigger not working in mobile app

it seems there is a problem with the placeholders. It will be fixed in the next SP.

Stefano Turcato
Presale Engineer
Hexagon Geospatial
Frequent Contributor
Posts: 114
Registered: ‎05-25-2016

Re: Trigger not working in mobile app

Man Sad Smiley Sad

 

I´ll have to wait then...

Isn´t there a price for the community member who finds more bugs?

Do you need immediate support?
If you encounter a critical issue and need immediate assistance please submit a Development Ticket through our Development Ticket Portal.